Problem setting up Wi-Fi on a set of new Reach modules

I am running into a problem setting up the Wi-Fi on the two new Reach modules I received last week (I assume that they are running the most recent version of Reachview although I can’t confirm). I am able to logon on to the module and set the name, security type and password for my Wi-Fi network. After I select the newly entered network in Reachview and click “Connect”, I start up the Android app “Fing” to look for the IP address of the Reach on the Wi-Fi network. It never shows up! The LED on the Reach remains a steady green - which I interpret to say that its in its “hotspot” mode and hasn’t connected to the Wi-Fi. It was green to begin with and never flickered. Should it? Do I need to re-boot (power-cycle) the Reach?

When the Reach first starts up the LED goes through several colors. The sequence is:

Magenta (steady for ~10 s)
White (briefly)
Yellow (flashing)
Alternating Magenta/Green (for ~10 s)
Green (Steady)

I tried re-booting the Reach after setting the Wi-Fi but the LED sequence and ultimate failure to connect to the Wi-Fi persisted.

I am inside a building so I don’t expect the GPS to see any satellites - but I don’t think this should prevent the Reach from connecting to the Wi-Fi network (it probably does explain some of the flashing LEDs)

Currently I am powering the Reach off a USB power brick.

Both of the Reach modules I received are doing this so I don’t believe it is a problem with the Reach module.

Any suggestions (and information on the LED color/behavior) would be much appreciated!

Hi, try giving reach access to satellite signals and make sure you wifi network allows reach to connect to it, or try a different network.
Also, you might wanna flash the unit a second time.

Reflashing made no difference. I also tried using a different USB cable (actually the one shipped with the unit). It might help if I knew what color the LED was supposed to be after I tell the unit to connect to my wifi network. It’s solid green before I issue the command (which I think is the correct color - its in “Hotspot” mode). I would expect the color to change to something else if it connects to the network - it remains solidly green. Until I connect to the network I’m going nowhere!

Hi, whats your status, any progress?

Green led, reach is hotspot mode or connectedto that one is hard to tell.
Have you tried following wifi troubleshooting:
-connect reach to a different wifi network or your phones hotspot
-make sure your wifi is set to assign DHCP, not static ip
-reach is in range of wifi
-credentials are typed in correct
-having a old router/wifi?, try a new one.
-Multiple wifi networks nearby?, this can cause interference if at same channel (1-16)

Well, I opened up a hotspot on an iPhone (I believe it uses WPA encryption) and I could see and access the hotspot from my laptop, but not the Reach (at least Fing didn’t see the Reach on the hotspot - it did see my laptop there).

The hotspot is using DHCP - it created dynamic IP addresses for other devices added to the hotspot.

The Reach is right next to the iPhone. Does the fact I am inside (so the Reach cannot see satellites) impact its ability to connect to WiFi network - I wouldn’t expect that.

The credentials are correct - I was able to use them to connect my laptop to the hotspot.

What does a Reach do if it can’t connect to the WiFi network, does it roll back to its own hotspot. If so how long does it try before giving up on connecting to the network?

Is there an alternate way to talk to the Reach (via USB?) to configure ReachView?

I guess I’m going to flash it again and try again.

This is very frustrating…to say the least!

Sounds like timesync issue

Or in combination of iPhone Hotspot problem

So if I understand you correctly, you

Create a hotspot on your phone
Power up the Reach - let it create its own hotspot (green LED)
Access the Reach hot spot from your phone
In the Reach wifi menu (not in Reachview?) set up a connection to the phone’s wifi network.

I guess the key point is the bit about “the reach’s own wifi menu”. How do I access that (if its not the procedure using Reachview that is described in the Reach documentation?

One more thing, what version of firmware did your flash with?
Connection problem could be anything. I have read so many posts with different solution its hard to pinpoint the area.

I believe it was 2.3 - I downloaded it off the Emlid site.

What about the Reach hotspot’s wifi set-up?

I decided to reflash the Reach. I attempted to follow the instructions in the documentation, first of all trying to follow the instructions for flashing the device using the GUI Guide. Here are some screen snapshots that I grabbed

This seemed different from what I expected given the instructions. The program wanted me to plug in the Reach - the instructions indicated that should already be plugged in. Nothing happens until I unplug and then re-plug it in. Then I get

The process continues (with no warning error messages)

Finally I get back to this - it seems to want to reflash the firmware

The process starts again!

This continues …

Note the amount of free memory - the process appears to be using up more and more available storage - without ever completing!

I decided to try the alternative command line method of flashing the firmware. The results weren’t any better. At first I followed the instructions given in the documentation (install the Edison drivers, unzip the downloaded image, unplug the Reach, cd to folder containing the image, run flashall.bat. I was then supposed to plug in the Reach and “monitor” the progress. That didn’t work, the batch job finished before I could plug in the Reach. I tried to run the flashall.bat WITH the Reach already installed. The results shown below weren’t any better, in fact I think the error message was the same as before!

What am I doing wrong?


I was able to solve my problem flashing the firmware using the command line approach by downloading a couple of files that the .bat file needed.

I got a message that the update had been successful and to wait while the Reach rebooted. The message implied that it would take about 2 minutes. The Reach did reboot, the LED changing colors several times ultimately reaching a state where it blinked white. It remained in this state for at least half an hour. Wish I knew what it meant! In the end I simply disconnected the Reach.

Tomorrow I will try one more time to get it to connect to my WiFi network.

Hi, seems like you got it right, hope you get it connected.
You actually got it right at image 5 and reach is flashed, no need to flash a second time.
The intel tool can be confusing.

Well I had no luck connecting to a hotspot on a cell phone. The Reach was right next to the cell phone. I was able to log on to the hot spot from another (Android) device so i know my credentials are good. Fing can see the devices attached to the hotspot - but that list doesn’t include my Reach. I have re-flashed the Reach. What else can I do?