Problem for upgrating Edge's firmware

After connecting my Edge device and QG recognise it => i click Connect
I receive a lot of :
info : Sending bootcode.bin
info : Device located successfully

but nothing else.


I have two Edge device and i try with both.

Can you help me ?



You can try to upgrade with Etcher.

Mine is up to date with version 1.5. I did it with QGC, but I do not remember if it was with my PC or my Mac…


Hello Marc,

Thank you for your help.

I don’t know how to use Etcher.
From which Image and Drive ?
Otherwise i try from an another PC with tje same issue :frowning:



There is a HowTo in the Emlid doc:

Emlid Edge image is compressed, you have to expand it to obtain an .img file.

Do not forget to install RpiBoot (windows only, no need for Mac OS). The error you have may be generated by missing RpiBoot drivers.

When the Pi drive is mounted by Windows, ignore the msg asking to format it (close the windows).

Before updating, save your parameters file in order to restore it on the new version. You still will have to calibrate acc and compass.


I try to use Etcher but i got an issue.
I installed RPI driver before and the Edge device is seen like this : BCM2710 Boot Raspberry Pi USB Boot.
After selecting the image i have this :
If i put an USB key instead in the same usb port it’s ok: i jump the step.
On QGC :

I use the PC micro usb port on Edge and the cable from Emlid
I can see the blue light wifi blinking on Edge


You could try another USB cable… and remove all plugs (GPS, Wifi,…) from the Edge.

There is some interesting documentation available:

Before using Etcher or GCS for flashing, you can try to follow the RpiTool steps (Windows Installer) and check that your Edge drive is mounted.

Edge is powered from the USB cable,

The Jumper4 item is not relevant for Emlid Edge.


I use your link, at step 4 i have :

I try with different cable, different port and different computer.


No luck,

What arducopter version is installed on your Edge? Does it work and fly?

Did you try with W10-64 computer and can you have access to a Mac?


I tried with W7-64
I will try with a MacBook soon.


Hi Thierry,

Do you have any updates?

Hi Tatiana,

I had contact with Thierry, Update went fine with W10-64 computer.



1 Like

Glad to hear it! I close this thread cause the issue is solved.