Problem connecting Mission Planner to Navio2

  1. Image and ArduPilot version.
    emlid-raspbian-20200922.img - whatever version of ArduPilot that came with the image

  2. Detailed problem description. How does observed behavior differ from the expected one?
    I cannot get Mission Planner to connect to the Navio2.

  3. Your step by step actions.
    I have tried all connection options: UDP, TCP, ( COM1 using a hard wire USB cable) and AUTO.
    All fail in various ways, from doing nothing, looping, saying that the connection was refused and
    that the port is already in use.
    In the case of UDP and TCP, I have tried different ports with no success.
    I have written my own program on my desktop to do a UDP connection, works fine.
    APM works great! It just doesn’t do all the stuff I need like calibrating the dual compass.

I am using A WiFi connection for all this.
Windows 10 desktop
Raspberry P4
Mission Planner is 1.3.74

Putty works great.
APM works great.

  1. Picture of the setup and connection scheme.
    Not much to see at this point, just the P4 and Navio2 mated together.

  2. If using any additional hardware please provide exact make and model.
    Nothing yet.

Hi John,

Welcome to the community forum and thanks for the detailed description of the issue!

Could you please share the configurations in launching file with me so I could also take a look at it? You can just post its content here.

Thank you for your response Liudmila.

Here is the contents of /etc/default/arducopter:

192.168.254.39 is the verified local address of the PI.

Default settings for ArduPilot for Linux.

The file is sourced by systemd from arducopter.service

TELEM1="-A tcp:192.168.254.39:5760"

#TELEM2="-C /dev/ttyAMA0"

Options to pass to ArduPilot

ARDUPILOT_OPTS="$TELEM1 $TELEM2"

                      #    # ###### #      #####

                      #    # #      #      #    #

                      ###### #####  #      #    #

                      #    # #      #      #####

                      #    # #      #      #

                      #    # ###### ###### #

-A is a console switch (usually this is a Wi-Fi link)

-C is a telemetry switch

John,

To make sure I got you correctly, is this the IP address of the computer where Mission Planner is installed?

Yes, sorry my mistake. It is the IP of my desktop where Mission Planner is installed.

Hi John,

May I ask you to change the TELEM1 parameter back to -A udp:PC_IP_address:14550? Then please run sudo systemctl daemon-reload and sudo systemctl start arducopter.

After this, please try to connect to Mission Planner. If the connection fails, it might be useful for me to check the screenshot of the error.