Problem achieving RTK FIX solution with RS+ over VRS service


In short: Problem achieving FIX solution with RS+ over VRS service

the story:

I have been using a pair of Reach rs+ receivers for a few years now but one thing keeps bugging me alot. I’m from Croatia and have a subscription to local NTRIP called CROPOS. I use this NTRIP in VRS mode for short baseline since i’m kinda in the center of 4 nearest base stations all around 40km from me, so I shouldn’t have a baseline problem unlike in single station mode.

Long story short i usually connect RS+ base to NTRIP and wait for FIX… sometimes it achieves fix solution in 10-15 minutes… sometimes i reboot receiver and try again and it is hit and miss will it achieve fix and It stays in float. I’m mindful of placement also, but on same place it achieves fix but another day on same place it won’t even when weather is fine. I’m observing GPS, GLONASS and GALILEO constellations (same as VRS) and have PDOP usually well under 2 (1.3-1.6 mostly). I’m using Elevation mask of 15 degrees, SNR mask of 35, and refresh rate of 5hz for base and rover. I usually have 20+ satellites, but VRS have a few less (17-19), and have 3-6 green satelites. Also firmware doesn’t have influence, always running latest.

When RS+ rover receives correction from RS+ base it stays fixed no problem as long i’m not near pine tree or building obviously, but reFIXes after. But i need that absolute position provide from NTRIP.

The test or a trial I conducted over last few days:

That got me thinking I maybe have defective Base unit… so i tried directly connect rover to NTRIP few days ago not using base station and at first to my surprise it got fix after 10 or so minutes in not so ideal conditions (some houses near office but there is clear sky around) twice with measurements being spot on for me (inside 3cm)

Next day I went outside town to take a test. it is kinda 100x100m open field with elevation changes with 10m tall trees with light canopy around and building. Anyway i connected rover to ntrip vrs and got fix solution after maybe 10-20 minutes of floating… fix was stable moving around, surveyed 8 points and rebooted rover for second try. It also got FIX in 10 or so minutes and i went to stake out surveyed points from 1st try and all of them were inside few cm.

Then I actually went to work after that test the same day with only a rover because it worked really well in the test. It got fixed after 10 minutes in a field with short olive trees and some short pine trees. After that i tried to intentionally lose the fix to see how long I have to wait for it to get back and it was as soon as I moved a few meters away from the pine tree. I staked out some old known points from earlier when I used rs+ base and rs+ rover and they were also spot on.

One thing to note is that the weather that day was the most beautiful weather one can wish for. Sunny, no clouds whatsoever, no humidity, no wind, and high visibility. I kinda thought that has to be the reason for high RTK performance i haven’t experienced so far…

Next day was not so great weather, light clouds, some light wind… and I went to the test location with base + rover. Mounted base and now it needed around 30 minutes to achieve fix (coincidently fix was achieved when light cloud cover dispersed and clear sky showed up). After it FIXed I connected over the lora rover and staked out 8 points from yesterday and they were all OK so no problems there. But then I turned off base and tried rover over ntrip but rover never achieved fix solution even after waiting for too long (almos an hour) and moving around the field. Weather was overcast with light clouds nothing special

So i went back to test location today again with only Rover. Nice weather, light wind some light clouds… and i couldn’t get FIX for hour and half of FLOATing. I got realy irritated and went to find flat open field with no trees and obstructions higher than 2 meters and even then NO FIX after 20 mins

The cry for help:

I mean I know RS+ is kinda cheap piece of kit in the GNSS world but come on… why can’t I get a reliable FIX solution. For absolute position I don’t care for sub cm accuracy, give me sub dm accuracy and i’m happy if i don’t have to wait for ages and not knowing will it achieve fix solution. Also Base + rover over lora no flaws whatsoever.

In the end I don’t know what the problem is. Is it my hardware, is it my position in the world (maybe one day i plan to drive to the nearest base station and try VRS and single station corrections to see what’s what), is CROPOS compatible with RS+ (should be). How long should I wait for a FIX solution? I’m not expecting seconds but inside 5-15 minutes is not bad in my mind.

Any input from other people having experience using RS+ in RTK with NTRIP would be greatly appreciated.

Thank you

1 Like

Hi Fabe,

Welcome to the forum!

Thank you for such a detailed description of your issue. Since, in some cases, you can get a Fix solution over an NTRIP and have no issue with the transmission of the correction over LoRa, it doesn’t look like an issue with RS+.

Single-band receivers need some time to get a Fix because they can only handle one type of frequency, the L1 frequency. So, Reach RS+ units are sensitive to environmental conditions and require an open field. If the Reach RS+ base is not placed in an open area, and you use a multi-band NTRIP service, it can explain why the NTRIP setup works better in some cases. Still, I’d like to dig deeper.

Please record the following logs in the open field for at least 10-15 minutes: raw data, LLH solution, RTCM3. You can send this information privately to The photos of the environment in which the logs are recorded will also help us to investigate.


Thank you Olesia for response . I have sent LOGs in mail today, so looking forward to reply. I’m aware of RS+ limitations regarding it being only single band antenna, so i’m afraid i’m asking to much from RS+ when connecting it to VRS… idk.

Anyway thank you once again and kind regards