PreArm: Mode not Armable

I’m trying to arm my drone, but I keep getting a message saying mode not armable. my flight mode are as follow:
Flight mode 1: Stabilize
Flight mode 2: Loiter
Flight mode 3: Loiter
Flight mode 4: Loiter
Flight mode 5: Loiter
Flight mode 6: RTL

I have already bind my remote control to the drone. when I do my throttle up to the right, it tells me that compass calibration is running. but, if I do it to the bottom right, it wont arm the drone.

can anyone please help me…

Hi Joseph,

Sorry for the delay!

When you arm the motors, the flight modes need to be set to one of the following options:

  • Stabilize
  • Loiter
  • ACRO
  • AltHold
  • PosHold

If you use an autonomous mode like RTL, switch the flight mode to Loiter or PosHold. Then wait until the LED blinks green, indicating a good GPS lock. For more details, please check this guide in Ardupilot’s docs.