PreArm: Logging failed, /var/lib/arducopter/logs is empty

I just installed the latest emlid raspbian image (20191128) on a Pi3 with Navio2.

I’m using mission planner in Windows 10 and connect via 3DR Sik radio.

The problem is that I can’t arm the drone with the error PreArm: Logging failed.

/var/lib/ardupilot/logs is empty.

LOG_BACKEND_TYPE is set to “file”

Hi Jacob,

Welcome to the community forum!

Is it possible to try another SD card with your current built to see if it makes any differences?

Could you please check if setting the LOG_FILE_BUFSIZE parameter to 8 would resolve the issue? You can also look through this Ardupilot’s forum thread where many other suggestions are discussed.