PPK in Online Service Fails

Our state surveyors assoc. provides rinex cors logs for ppk workflows. They also have an online utility to do the post processing. I had never used it before, but decided to see how it compares to results in ES.

When inputting the RS2 obs file, the utility throws an error that “dual freq. data is required, but not available”

I know that error messages can be off the mark, so I’m not sure what the utility is looking for and not finding in the RS2’s observation. Here is a link to the observation I’m trying (I’ve tried a couple others with the same result), and a rinex obs. file from the service for comparison. Perhaps it is a particular formatting it is not seeing? I’m not sharp enough with rinex files to be able to troubleshoot.

The point processed fine in ES.


[edit for grammer]

Hi Dave,

A couple of ideas:

  1. Try converting the file to rinex 3.02. I’ve used an online ppk processor from Leica and even though it said it could process up to rinex 3.03, it wouldn’t process those files from the RS2.

  2. Some GPS satellites still in orbit do not include the the L2C signal, so they come in as L1 only on the ublox chips. This can cause errors in some ppk software. You should be able to exclude these satellites and make a new rinex file without them. I’m not sure how to do this in ES, but I’m pretty sure this can be done with rtkconv in rtklib.

1 Like

Likely the service is so dated that it doesn’t see anything else but GPS L2P for L2. The RS2 series only tracks the more modern GPS L2C.


Thanks for the insight, guys. I’ll do some logging using rinex 3.02 and submit that. If that doesn’t do it, I’ll abandon trying to use the service.

Hi Dave,

I agree with Christian’s and @Africawaterdoc’s suggestions about the L2P/L2C signals. You can open the log in Emlid Studio and see that these signals are almost the same in the plot:

Most likely, this service indeed requires outdated L2P signals, while Reach RS2+ tracks newer L2C ones.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.