Power Module with OOBF?

Hi. I am just starting to use my Navio 2 that I recently ordered using Order #12562
The Navio 2 board itself is working as it should. But now that I have started to wire up my rover I tried to power my Navio using a 7.4V Lipo battery using the power module. I got no power to the board.
I tried with another battery, and 11.1v battery that I use on one of my Navio drones and got the same result- no power.

I switched out the power module with one from a prior project and it worked. So it looks like the power module supplied with my order is faulty.
Is there anything else I should do to verify if that is the case? I have contacted your support a week ago but after an initial hold email they never got back to me.

Sorry it’s taken us so long to reply.

Do you have any measurement equipment? A simple multimeter would do. If you have one, could you please tell what voltage is on the DF-13 connector you’re connecting to Navio 2.

Sorry for the delayed reply. Have been travelling and just getting back into this stuff.
Just had a poke at it and I am getting 6.9v through the XT60 connector which makes sense given I am testing with a 2s 1000mAh lipo.
I just can’t get any voltage readings off the DF-13 connector.

@Bradley_Scott looks like something is wrong with the power module. Please send an email to support@emlid.com with a link to this thread and your order number and we will arrange a replacement for you.

This topic was automatically closed after 100 days. New replies are no longer allowed.