Post Processing using RTKLib, not getting fix solution

  1. Firmware image and ReachView version.
    2.4.3 b28 RTKLib

  2. Detailed problem description. How does observed behavior differ from the expected one?
    I am using Emlid reach Module mounted on UAV. I am taking test flight to test accuracy of emlid reach. I cannot get all points fix while processing in PPK mode. My baseline is <1 Km. I thought with such small baseline I would get all the points as fixed but getting only about 70% fix. Can anyone tell me how to get good percentage of fix? Are there any guidelines to be followed to get good results? I have

  3. Your step by step actions.
    I have taken 4 Flights. I didnt turn off the emlid reach of drone to avoid doing cold start everytime. I observed that at start of every flight, I am getting float results and after sometime, It get fix. Each float line represent starting path of flight in the figure given below
    I have followed post processing tutorial from emlid website. And following were my settings.

  4. (

6) Raw Files
Base -
Rover -
Base location - 30.712191133, 76.668984443, 265.6320

Hi Manish,

Thank you for the detailed report!

From the log files, it seems that some electronics on your UAV produce interference. Please try shielding you Reach and antenna cable.

The base station log isn’t that good either. Could you please post the photos of your base station setup?

1 Like

Thanks dmitriyershov.
Can you tell me how to interpret this graph which you have posted?
This is my UAV setup. Emlid module is under the antenna


While you wait for Dmitiry to reply, you might try changing Filter type from Forward to Combined, and you will probably see some more fixes in your solution file. Change it on this page:


1 Like


On the graph, you can see a lot of red markers, they stand for cycle slips. In order to get rid of this issue, you need to follow the instructions from our docs, please take a look at this entry:


I warped copper foil around reach module to reduce interference. I am getting very good results. It was indeed because of interference/noise. Thanks for the help


Neat improvement !
May be wifi : I always disable wifi on reach module before flying …


I’d also recommend placing rover’s antenna on a separate 100x100mm ground plane.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.