Possible bug - sat loss in raw when changing RTK settings

Hi, I am seeing a wierd issue running 2.14 on RS+. If I change things like SNR mask or Elevation mask, I get a dropout of satellites, only recoverable by shutdown and then restart (reboot from the app doesn’t mitigate the bug).
This affects the raw-file as file, which shouldn’t happen.
This is the first run after update to 2.14, so I did correct a few things like sample rate (which obviously will affect the raw), and NTRIP input (shouldn’t affect the raw, but seem to do that (see the outtage at 05:55 i.e. and later when I changed NTRIP supplier)

Attached are a few screenshots to illustrate:

Raw file
raw_201808160551_UBX.zip (662.1 KB)

Yep, I’ve seen it once too. How reproducible is it for you? Does it happen every time?

Almost all the time. Was also there on the previous firmware, so nothing new to 2.14 as far as I can tell. Still annoying as hell, mostly because you need to restart the logging.

Thanks for reporting this! It is a weird bug, but we already have a fix in the pipeline, so it should be out in one of the next versions.

1 Like

Will it be pushed to the beta 2.15? Then I might contemplate signing up for that programme.

Not to detract from the situation here, but curious from the photos. Isn’t setting the receiver flat on something like that no different than setting it flat on the ground? Should it be elevated off of it due to multipath?

I know when I set mine flat on the ground, it’s not good. Then on survey pole, all good.

Yep, some elevation is always better, but this was just a quick-and-dirty measurement, not something exact

1 Like

Not yet sure at this point, but likely it will be pushed to both channels as it is a bug fix.


I’m sure it would have already been brought up if it might have helped, but I wonder if you have tried “Reset settings to default”; reboot, and see if you get the same results.

After the problem has occured, you mean?

Correct. Not to be too cheeky, but you can’t go back in time and do it. … wait a minute … :alien: … or can you? :thinking:


I should explain a bit: I mean to do this in the chance that you got some glitch in your device’s configuration file. If so, this could potentially clear it.

I see what you did there :stuck_out_tongue:

While I have tried clearing the ini-file a few times (which didn’t help), I didn’t try selecting systems. I’ll do that in a few hours.

1 Like

Yeah, I think Igor would have already mentioned it if he thought it would help. It never hurts to try though.

I think because of the relatively small length and width of that brick top, plus the height of the surface above the surrounding ground… I think the antenna should get good quality reception there, even sitting directly on the brick. Now if it was a larger brick floor, then no, and if it was upsloped or had walls, then for sure no, don’t put it directly down on the surface.

At least from the speed of fix from Euref CORS, 100-something km away, the antenna had good working conditions. Usually take many minutes.
Probably also a side-effect of 2.14 firmware.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.