Poor RS2 Radio Range

I brought a couple of RS2 units a while back and have never managed to get a decent baseline between the base and rover. I gave up and reverted to using our Topcon Hiper V but am now back on the case as I need to get these RS2 working. I am using all the recommended settings for LoRa but can only manage about 500m before the link drops out, and this is in flat open terrain. I have matching frequency (918.1) , output power (20db) , and air data rate (9.11 kb/s), the base is in Base Mode and the Rover correction inputs are setup correctly. Any advice?

Hi Will,

Are there any severe obstacles like buildings between the base and the rover? LoRa is low-powered radio which requires a line of sight between receiver and transmitter.

1 Like

Hi Tatiana,

Yes this is in clear, flat, open terrain. It is line of sight between the base and rover. I am reading people getting 10,20, even 40km baselines. Something must be wrong?

Will.

Maybe try a different frequency ,as interference can cause the issue ., What is the correction time on the main display?

1 Like

Curious, can LoRa work over about 5 to 10km over rolling hills, trees etc. without a straight line of site? Or is straight line of site “mandatory”? (Isn’t max 8km?)

I.e. set base up on a published benchmark monument. Enter known lat long coordinates and elevation (ellipsoidal height correct? Not orthometric correct? I have both for benchmark).
Survey 5-10km away with rover.

I typically work much shorter distances in line of site, so never tried the above scenario.

I will try a different frequency, there wouldn’t be a correction time if the solution is single no?

Hi David, so I tried other frequencies, also tried swapping base and rover roles. I can get no further than 500m baseline (line of sight, I can see the Base). At around 500m base corrections drop out, rover goes to single solution with 0.0 sec age of differential. Will.

Correct.

can you post screenshots of the correction pages of your base and rover?

Hi Will,

Please also share the Simple system report from both units. It’ll help me to check all the settings on the units. You can post the reports here or send them via support@emlid.com. You can find the Simple system report on the Settings page of the ReachView app.

Base

Simple system report
app version: 2.24.2-r0
'wifi_status, interface: wlan0':
- wifi_mode: ap
- access_point:
    band: bg
    channel: 1
    password: null
  ip: 192.168.42.1
  is_added: true
  is_connected: true
  mac_address: 6C:21:A2:8F:80:7C
  security: wpa-psk
  ssid: ReachRS2_Base:21:55
  uuid: f72a9074-89e2-4e0b-b363-ed7b3f4caf94
base mode:
  base coordinates:
    accumulation: 2.0
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - 0
    - 0
    - 0
    format: llh
    mode: single-and-hold
  output:
    air_rate: 9.1099999999999994
    enabled: true
    frequency: 922800
    io_type: lora
    output_power: 20.0
  rtcm3 messages:
    '1006':
      enabled: true
      frequency: 0.10000000000000001
    '1074':
      enabled: true
      frequency: 1.0
    '1084':
      enabled: true
      frequency: 1.0
    '1094':
      enabled: true
      frequency: 1.0
    '1124':
      enabled: true
      frequency: 1.0
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
constraints:
  lora:
    frequency:
    - - 918100
      - 925900
correction input:
  input2:
    baud_rate: 38400
    device: UART
    enabled: false
    io_type: serial
    send_position_to_base: false
device:
  night_mode: false
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  usage_analysis_accepted: true
logging:
  base:
    format: RTCM3
    started: true
  correction:
    format: RTCM3
    started: true
  debug: false
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
  solution:
    format: LLH
    started: true
lora:
  air rate: 9.1099999999999994
  frequency: 922800
  output power: 20.0
network:
  tcp_over_modem: false
position output:
  output1:
    baud_rate: 38400
    device: UART
    enabled: false
    format: ERB
    io_type: serial
  output2:
    baud_rate: 38400
    device: UART
    enabled: false
    format: ERB
    io_type: serial
rtk settings:
  elevation mask angle: 15
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: 1.0
  max vertical acceleration: 1.0
  positioning mode: kinematic
  positioning systems:
    compass: true
    galileo: true
    glonass: true
    gps: true
    qzss: true
  snr mask: 35
  update rate: 1
sound:
  mute: false
  volume: 100

Rover

Simple system report
app version: 2.24.2-r0
'wifi_status, interface: wlan0':
- wifi_mode: ap
- access_point:
    band: bg
    channel: 1
    password: null
  ip: 192.168.42.1
  is_added: true
  is_connected: true
  mac_address: 6C:21:A2:BF:70:26
  security: wpa-psk
  ssid: ReachRS2_Rover:E7:BC
  uuid: c353127e-6100-4108-86fa-3bcf7bf30020
base mode:
  base coordinates:
    accumulation: 2.0
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - 0
    - 0
    - 0
    format: llh
    mode: single-and-hold
  output:
    baud_rate: 38400
    device: UART
    enabled: false
    io_type: serial
  rtcm3 messages:
    '1006':
      enabled: true
      frequency: 0.10000000000000001
    '1074':
      enabled: true
      frequency: 1.0
    '1084':
      enabled: true
      frequency: 1.0
    '1094':
      enabled: false
      frequency: 1.0
    '1124':
      enabled: false
      frequency: 1.0
bluetooth:
  discoverable: true
  enabled: true
  pin: '***'
constraints:
  lora:
    frequency:
    - - 918100
      - 925900
correction input:
  input2:
    air_rate: 9.1099999999999994
    enabled: true
    frequency: 922800
    io_type: lora
    output_power: 20.0
    send_position_to_base: false
device:
  night_mode: false
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  usage_analysis_accepted: true
logging:
  base:
    format: RTCM3
    started: true
  correction:
    format: RTCM3
    started: true
  debug: false
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
  solution:
    format: LLH
    started: true
lora:
  air rate: 9.1099999999999994
  frequency: 922800
  output power: 20.0
network:
  tcp_over_modem: false
position output:
  output1:
    baud_rate: 38400
    device: UART
    enabled: false
    format: ERB
    io_type: serial
  output2:
    baud_rate: 38400
    device: UART
    enabled: false
    format: ERB
    io_type: serial
rtk settings:
  elevation mask angle: 15
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: 1.0
  max vertical acceleration: 1.0
  positioning mode: kinematic
  positioning systems:
    compass: true
    galileo: true
    glonass: true
    gps: true
    qzss: true
  snr mask: 35
  update rate: 5
sound:
  mute: false
  volume: 100

Get Outlook for iOS

Clear line of sight Lora has massive range

Trying to propagate out of trees and valleys is very poor, put your base on the highest clearest point possible. I have tried a 1W external Lora, it barely made a difference fighting trees.

Raising the antenna improved performance in all cases.

2 Likes