Poor M+ signal => No Fix

Hi Emlid community. I have both M+ and M2, but Im having trouble with my M+ signal.
Im only having around 20% of fix after PPK and the reason must be the week signal the system is getting. Im getting in green (good signal) only 2 or 3 sattelites only meanwhile on the M2 I get 18 easely.
Im using 10cm metal ground plate with full sky view and still I get this results. Please help me find the problem.


Here is the Simple Report:

app version: 26.6-r0

current_network:

ip: 192.168.42.1

security: wpa-psk

ssid: reach:74:0E

enabled: true

mode: hotspot

base_mode:

base_coordinates:

accumulation: '120'

mode: single-and-hold

output:

io_type: tcpsvr

settings:

  cloud:

    mount_point: ''

  lora:

    air_rate: 9.1099999999999994

    frequency: 902000

    output_power: 20

  ntripsvr:

    address: ''

    mount_point: ''

    password: '***'

    port: -1

  serial:

    baud_rate: 38400

    device: ttyEXTS0

  tcpcli:

    address: localhost

    port: 9001

  tcpsvr:

    port: 9000

rtcm3_messages:

message_1002:

  enabled: true

  frequency: '1'

message_1006:

  enabled: true

  frequency: '0.1'

message_1010:

  enabled: true

  frequency: '0.5'

message_1097:

  enabled: true

  frequency: '0.5'

message_1107:

  enabled: true

  frequency: '0.5'

message_1117:

  enabled: true

  frequency: '1'

message_1127:

  enabled: true

  frequency: '0.5'

bluetooth:

enabled: false

pairing:

discoverable: false

pin: '***'

camera_trigger:

duty_cycle: 20

enabled: false

period: 2

reverse_polarity: false

correction_input:

base_corrections:

io_type: serial

settings:

  bluetooth:

    send_position_to_base: false

  cloud:

    mount_point: ''

    send_position_to_base: true

  lora:

    air_rate: 9.1099999999999994

    frequency: 902000

    output_power: 20

    send_position_to_base: false

  ntripcli:

    address: ''

    mount_point: ''

    password: '***'

    port: -1

    send_position_to_base: true

    username: ''

  serial:

    baud_rate: 57600

    device: ttyEXTS0

    send_position_to_base: false

  tcpcli:

    address: localhost

    port: 10001

    send_position_to_base: true

  tcpsvr:

    port: 10000

    send_position_to_base: true

device:

privacy_policy_accepted: true

role: null

usage_analysis_accepted: false

logging:

logs:

base:

  autostart: false

  format: RTCM3

  started: false

correction:

  autostart: false

  format: RTCM3

  started: true

raw:

  autostart: true

  format: UBX

  rinex_options:

    logging_interval: 1

    marker_name: null

    pole_height: null

    satellite_systems:

      beidou: false

      galileo: false

      glonass: true

      gps: true

      qzss: false

      sbas: false

  started: false

solution:

  autostart: false

  format: LLH

  started: false

settings:

debug: false

interval: 24

overwrite: true

position_output:

output1:

io_type: serial

nmea_settings:

  bluetooth:

    gga:

      enabled: true

      update_rate: 1

    gsa:

      enabled: true

      update_rate: 1

    gst:

      enabled: true

      update_rate: 1

    gsv:

      enabled: true

      update_rate: 1

    main_talker_id: gn

    rmc:

      enabled: true

      update_rate: 1

    vtg:

      enabled: true

      update_rate: 1

    zda:

      enabled: true

      update_rate: 1

  serial:

    gga:

      enabled: true

      update_rate: 1

    gsa:

      enabled: true

      update_rate: 1

    gst:

      enabled: true

      update_rate: 1

    gsv:

      enabled: true

      update_rate: 1

    main_talker_id: gn

    rmc:

      enabled: true

      update_rate: 1

    vtg:

      enabled: true

      update_rate: 1

    zda:

      enabled: true

      update_rate: 1

  tcpcli:

    gga:

      enabled: true

      update_rate: 1

    gsa:

      enabled: true

      update_rate: 1

    gst:

      enabled: true

      update_rate: 1

    gsv:

      enabled: true

      update_rate: 1

    main_talker_id: gn

    rmc:

      enabled: true

      update_rate: 1

    vtg:

      enabled: true

      update_rate: 1

    zda:

      enabled: true

      update_rate: 1

  tcpsvr:

    gga:

      enabled: true

      update_rate: 1

    gsa:

      enabled: true

      update_rate: 1

    gst:

      enabled: true

      update_rate: 1

    gsv:

      enabled: true

      update_rate: 1

    main_talker_id: gn

    rmc:

      enabled: true

      update_rate: 1

    vtg:

      enabled: true

      update_rate: 1

    zda:

      enabled: true

      update_rate: 1

settings:

  bluetooth:

    format: NMEA

  serial:

    baud_rate: 57600

    device: ttyEXTS0

    format: NMEA

  tcpcli:

    address: localhost

    format: ERB

    port: 9000

  tcpsvr:

    format: LLH

    port: 9001

output2:

io_type: tcpsvr

nmea_settings:

  bluetooth:

    gga:

      enabled: true

      update_rate: 1

    gsa:

      enabled: true

      update_rate: 1

    gst:

      enabled: true

      update_rate: 1

    gsv:

      enabled: true

      update_rate: 1

    main_talker_id: gn

    rmc:

      enabled: true

      update_rate: 1

    vtg:

      enabled: true

      update_rate: 1

    zda:

      enabled: true

      update_rate: 1

  serial:

    gga:

      enabled: true

      update_rate: 1

    gsa:

      enabled: true

      update_rate: 1

    gst:

      enabled: true

      update_rate: 1

    gsv:

      enabled: true

      update_rate: 1

    main_talker_id: gn

    rmc:

      enabled: true

      update_rate: 1

    vtg:

      enabled: true

      update_rate: 1

    zda:

      enabled: true

      update_rate: 1

  tcpcli:

    gga:

      enabled: true

      update_rate: 1

    gsa:

      enabled: true

      update_rate: 1

    gst:

      enabled: true

      update_rate: 1

    gsv:

      enabled: true

      update_rate: 1

    main_talker_id: gn

    rmc:

      enabled: true

      update_rate: 1

    vtg:

      enabled: true

      update_rate: 1

    zda:

      enabled: true

      update_rate: 1

  tcpsvr:

    gga:

      enabled: true

      update_rate: 1

    gsa:

      enabled: true

      update_rate: 1

    gst:

      enabled: true

      update_rate: 1

    gsv:

      enabled: true

      update_rate: 1

    main_talker_id: gn

    rmc:

      enabled: true

      update_rate: 1

    vtg:

      enabled: true

      update_rate: 1

    zda:

      enabled: true

      update_rate: 1

settings:

  bluetooth:

    format: NMEA

  serial:

    baud_rate: 38400

    device: ttyEXTS0

    format: ERB

  tcpcli:

    address: localhost

    format: ERB

    port: 9000

  tcpsvr:

    format: LLH

    port: 9001

positioning_settings:

elevation_mask_angle: 15

glonass_ar_mode: true

gnss_settings:

positioning_systems:

  beidou: false

  galileo: true

  glonass: true

  gps: true

  qzss: false

  sbas: false

update_rate: 5

gps_ar_mode: fix-and-hold

max_horizontal_acceleration: 1

max_vertical_acceleration: 10

positioning_mode: kinematic

snr_mask: 35

Can you share the raw log files? Then it is much easier to say something qualified.

Hi Christian, I attach two logs: With groundplate a without groundplate

Without Ground Plate.obs (2.2 MB) With Ground Plate.obs (2.2 MB)

Hi Dann,

The rover’s data quality is indeed not high. Usually, it happens if RF noise from motors or onboard electronics causes RF interference. Can you send a photo of your setup for a check?

Also, please share the raw data logs from the base. I’ll post-process the base and rover data together to check if the solution can be improved.

Hi Kseniia, I attach the following logs:

  1. Log of M+ flight
  2. Log of Base antenna
  3. Log of M+ with M2 antenna (Try different antenna with the same results)

Link for download:
https://drive.google.com/drive/folders/1whRl5fMEfZMCsYC-gKzEdx8-YpI61IIl?usp=sharing

Thanks for your help,

Hi Dann,

Thanks for sharing the logs, and sorry for the confusion with the photo. I meant a photo of your drone setup with Reach M+ installed. Can you send it too?

Kseniia the log I sent you was mounted on a camera pod we design to be used in manned airplanes, but did several tests with the system standing alone and got the same results.

Daniel B

Hi Daniel,

I’ve checked the logs from your flight. You can see regularly appearing cycle slips, which means satellite signals were interrupted:

It can happen if the signal reception is affected by RF noise. In your airplane setup, different electronics and wires are placed pretty close. I’d recommend keeping them farther from one another, but it can be challenging to do in the limited space. So, I’d suggest at least protecting your Reach M+. I know some of our users used aluminum foil for that.

I don’t see the GNSS antenna in the photo. Does it stand far enough from other electronics? Are there any physical obstacles around it?

the log I sent you was mounted on a camera pod we design to be used in manned airplanes, but did several tests with the system standing alone and got the same results.

Please share the base and rover logs from the test with a standalone system. Did the antenna have a 30 degrees clear sky view?

Hi Ksennia, I replace the M+ with the M2 from the system because of the problems we are having. I already tried shielding the M+ with aluminum foil and still no good results.
Here I attach the logs from the last test I did in the roof of my building with full clear sky view and the system standing alone with none electronic devices near.

https://drive.google.com/drive/folders/1eBHNS3DU4jb2uTp7-WUewXhyWX_qUxx4?usp=sharing

Thanks! I’ll look into them.

Your sample is very short. A 2-4 hour sample would give a much clearer indication.

Hi Daniel,

SNR of some signals changed periodically, so it still looks like RF interference took place. Please share a photo of the roof setup.

Christian made a good point: a longer log is more helpful to reveal the reason for this issue. We usually recommend collecting the logs for at least 10-15 minutes, but bigger is better.

1 Like

I did make another test leaving the system more time in my rooftop.
In the Rover files are the photos of the system config.

Hi Daniel,

Glad to see you back!

There are periodic SNR level changes, but the effect is not so serious as in your flight data:

I believe that the cables on the roof could affect the signals this way. Reach M2 indeed can handle such conditions better since it’s a multi-band device.

The data you shared is not bad in general. I’ve got 98% Fix in Emlid Studio with the default settings + Combined Filter type. You can try these settings out.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.