Poor GPS Reception, Very Little Fix

Hello to the Community, hoping for some steer on a little issue I’m having on a fixed wing mapping aircraft.

I seem to be getting very poor GPS reception on my Reach M+ unit. When I look at the SNR chart on the Status screen, I generally have very few green/fix bars, and for much of the time there are no green bars at all. I also did a test flight recently which confirmed only 53% of the flight was in Fix – see image below from RTKPLOT. I have even mounted the antenna on an extended stalk and also used a good sized copper ground plane – see photo.

These are my settings in RTK tab:
Positioning Mode: Kinematic
GPS AR Mode: Fix and Hold
Glonass AR mode: On
Elevation Mask Angle: 15 deg
SNR Mask: 20
Max Acceleration: vert and horiz set to 1m/s2.
GNSS used: GPS, Glonass and SBAS
Update Rate: 5Hz

To confirm, I am not using correction input, as I do PPK using Ordnance Survey base station data for Rinex correction data.

Appreciate any guidance.

Thanks,
Jacques

You will have to increase your ground plane significantly. 6-10 cm diameter, or choose a helix type gnss instead.

3 Likes

Hi Christian, thanks for your reply.

If it needs such a big ground plane, then why would the manufacturer not build this in as standard? Others seem to be getting good reception with no ground plane at all.

Jacques

Put your SNR MASK back to 35, not 20.

Use as many satellite constellations you can in your area and able to keep 5Hz Update Rate. (Add GALILEO ETC) Enable only the RTCM3 messages you need. Start low qty and Hz as to not overload.

What part of the world you in?

You can also try swapping out GLONASS for BEIDOU if BEIDOU giving better performance depending on time of day and their locations. Something you can play with later. Try GLONASS with AR MODE ON.

Agree with @wizprod. He is PRO user. :wink:
https://docs.emlid.com/reachm-plus/antenna-placement/

Tallysman TW4721 requires ground plane no less than 70x70mm.

1 Like

Because some users may stick the antenna to the metal roof of a vehicle, or the top of a metal enclosure. The antenna is used for many purposes (not just for aircraft).


Also, how is the excess cable routed? Maybe you are picking up interference.

2 Likes

Hi All, thanks for your replies. I had much better Fix on my latest test, see image below. Not really sure why there is such a big difference, the higher SNR mask is likely helping (thanks @timd1971). Also, my first flight may have been at a time with exceptionally low # satellites. Although, I am in the UK so should expect decent coverage. I did try swapping some of the GNS systems used, but GPS/GLONASS/SBAS seem to be giving me the best results.

@wizprod and @davehofer1993, thanks for the info about the ground plane size requirement. I had no idea it would need to be at least 70 x 70 so big (mine is only 60mm diam).

@bide, thanks for the reminder about cable routing. My excess is sitting in a loop amongst some servo wires and also runs past motor wiring, VTX wiring, camera, etc. I have a spare Tallysman and I’ll do a ground test with cable running clear of everything else to see if that makes any difference. Is there a way of reducing interference, eg. by looping or shielding?

One more question - if I were to try a helical-type antenna, can anyone suggest what to try? Are there any plug 'n play options that will work with Emlid?

Thanks,
Jacques

2 Likes

You need to add GALILEO.

Try swapping out GLONASS with BEIDOU.

You have about double the amount of BEIDOU sats at that time and approximate location. (L1)(15 deg elev mask)

2 Likes

Thanks @timd1971, just downloaded that app, really useful!

Jacques

1 Like

Also note that your baseline is a little long for L1 only. When over 10 km, precision starts to suffer.
When struggling with getting a fix, a long baseline doesn’t help either.

3 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.