Points not showing when I export to DXF

When I export the DXF file with point labels or just as a DXF, the actual point does not show up in the DXF file. I get the label and the height, but that is it.

Screenshot 2022-08-31 134150

It does import a layer called “0,” but nothing is on that layer. There are only 3 layers that import, height, name, and 0.

Even though it doesn’t appear is there something to snap to? Or a node when you select the text? Have you tried exploding the block?

I haven’t used the Reach app for work, but does it generate two files, DXF and a csv point file? I use Microsurvey FieldGenius Android version and it generates the two files among others, that I then bring both into Microsurvey CAD to work with. I need both files in order to see Point #, Name, Code, Elev., N/E and linework. I wonder also if you have to change the point symbol/color from a “.” to a cross-hair type symbol in order to see it. That sometimes happens to me when I bring in another engineers work.

Hi @CoreysConstruction,

What coordinate system do you export the project in? Does the same issue happen when you export the project in any other format?

1 Like

A DXF is just a graphical representation of the CSV. The problem is that different CAD packages use different block formatting for point entities so there’s really no standard for a point between them. Carlson, Civil 3D and MicroStation all have their own formats just like they do for TINs even though they’re the same thing. Can you not just import the CSV and draw entities?

1 Like

Hi Michael, yes that is certainly one way to do it and I have done it that way, taken only the .csv file and worked with it for producing a new drawing or bringing it into a existing drawing. I do like the convenience of having the linework and the points available when shooting as-builts and then exporting them to CAD. It retains the linework done in the field.
Having not used the Reach software for shooting points, I wasn’t sure how they handle the graphic portion of the point. Is it simply a point “.”, which I assume it is because they don’t offer linework at this time. DXF is limited to what it displays vs DWG files on some data collectors.
I have found that FieldGenius Android doesn’t display anything in a CAD Block on the data collector for instance.
For instance, in Topcon Magnet software I also use with different instruments, it can display color layers and is much more robust in what it displays because it can work with DWG files.
Also in CoreysConstruction example above, it seems like the Reach software would have displayed a point # along with the name and elevation and that would have come normally from a csv file. I’ll definitely have to play with the Reach software this weekend and see how it functions when you export the files.
I normally use FieldGenius, which as you know displays linework and the points on the data collector, which is part of the reason I purchased it along with it’s other attributes.

On another note, I just purchased a Autel Robotics EVO II Pro 6K Enterprise V2 drone with the RTK accessory and might ask you some questions on it if I can’t figure it out. I don’t think I’ll have any problems because of the information I have been able to find online so far, but you never know. I also own a EVO II Pro, but I wanted a RTK capable drone to eliminate some of GCP’s/Ctrl. Pts. I currently use. Still going to place some, but just not as many as I have in the past.
Regards, Mark

1 Like

That’s because they have their own format. It is still a symbol. It just has attributes which I agree with the functionality of linework being similar. An X is a block, two lines. If you bring a symbol X (not the letter) into CAD you can explode it. In Carlson we can make points by a symbol including nodes but there is still a 3rd step there.

We use Topcon as well for layout and machine control. They and Trimble are extremely proprietary. All project files and derivatives thereof cannot be read by anything other than their software. It would be a peach if I could use their localization in Reachview or Fieldgenius Android but nope.

Absolutely let me know if I can help with the E2P RTK. We need to continue to get a community of that drone specifically because in my opinion it is the P4RTK killer. There are a couple of bugs that we have experienced but Engineering is on it and they need Terrain Following and Corridor flight but it will come as long as we keep pushing on them.

Are you on the Autelpilots forum?

1 Like

I agree with that statement!

I’m not but will join this weekend. The unit is supposed to arrive late tomorrow.
Thanks, Mark

1 Like

Well that makes for an exciting weekend. Make sure to take you time on initial setup and calibrate the imu before you do anything. Really take your time getting a level board. I use a piece of plywood and put legos under each corner and measure with a digital level. I use an app called Bubble Level on Android. I’ve checked it against my 4ft and it’s spot on. Then the camera. Of course you’ll have to go outside for the compass obviously. I only stress this because we had some yaw issues in the beginning because I trusted the factory “calibration” but what I’ve learned is that environment has a lot to do with how the drone acts. I was in a radio heavy area today and when I started the mission the drone was yawed right about 15deg. I have seen this before on Phantoms and there was no fix. Even though I calibrated last week I did another full calibration in the field and it flew beautifully. Beyond that there’s a few software bugs that need to be taken care of and those two features I mentioned and we’ll be ready to scale and phase out the 4th gen Phantoms.

2 Likes

Use PDMODE, PDSIZE

2 Likes

Thank you for the helpful tips, very good to know!

Thank you, I had used these commands before, but kind of forgotten about them lately. I’m also able to set it at 5% of the drawing size and usually use that option.