Piksi with Navio+

I have been trying to get a piksi working as second gps. I ran through the same steps to get it working as with the pixhawk on both the navio apm build as well as the navio-plus-rtk which has the updated second gps -E port support. Still cant get the piksi to talk as the status in mission planner is still 0. Am I missing something?

Same problem here Dom.
I have tried changing the baud rates on every serial port to 115200 and protocol to 5 (GPS) on ArduPlane´s parameters but just couldn´t get it to talk to each other.
I also tried starting ArduPlane with -E /dev/ttyAMA0 and -B /dev/ttyAMA0 but nothing changed.
If anybody got it working, please shed some light on us…

Are the GPS default baud rates 38400 like the UBLOX?

Piksi’s baud rate can be configured in the Piksi Console application. I’ve set mine to 115200.
I’ve also set the baud rate of the serial port 1 to 115200 on Mission Planner but no luck.
The only thing I’ve figured out by now is that the Piksi’s original Pixhawk UART cable has TX and RX cables inverted (TX to TX and RX to RX), so you have to swap them in order to get GPS data to the serial port…