PID value questions - with video

I thought I’d make a new thread about this so its easier for other people to find.

I was having problems with my drone crashing right from the start. After seeing the video I posted, it was said that I either have a PID problem or ESC problem.

Since I can’t do anything immediately about my ESCs, I thought to try the PID.

I lowered it from .150 to .100 and it was more stable, but still way too wobbly. I wanted to lower it to .5 but mission planner stopped at .800. I tried it there and now can get it into the air reliably. But it still wobbles.

Two questions:

First, why can’t I go below .800? I wanted to go even lower and then work my way back up.

Second, what do I need to look at to fix the slight wobbles after I move the control sticks.

Thanks!

Here is the video. Please let me know what I should tune to fix the stability issues.

And for some reason, I can’t drop the values to 0. P only goes to .080. I only goes to .040 and D only goes to .001

I’d like to thank my wife for facing the cold and recording it for me haha.

Nathan, can you post the logs from this flight? Which mode was this flight in?

Good to know you are starting to get results, :), thanks

Please, provide your pids print screen (all screen) and more details about your hardware (motor kv mainly).

AND, do not fly high until get everything working fine.

The flight mode that this was in was stabalize mode. I tried in an alt hold to see what happened and had similar results.

How do you want me to post the logs? I have them as a large text file and a bin file.

I will get a screenshot of my current PID screen when I get home today.

I don’t know how to post the logs other than pictures of the graphs. I can upload pictures fine but I’m not sure how to upload a large text or bin file.

Here is the picture of the PIDs I’m trying. I can’t move the values any lower, mission planner just simply wont let me. When I try to type a lower number it just snaps back to what you see. When I push the down arrows on them, nothing happens.

The only values I’ve adjust are the PID values in the Rate Roll box (which are locked to Rate Pitch). Are these the right ones?

Hardware is the quanum 700 frame, 400 KV motors (integrated ESC, here is the link: http://www.hobbyking.com/hobbyking/store/__82874__Black_Widow_3508_400Kv_With_Built_In_ESC_CW_CCW.html), 6s battery, Power module capable of 10s, Navio2, Raspberry Pi, 12v and 5v combo BEC. Anything else that might affect it?

Nathan,

Rate roll and Rate Pitch parameters already looks too “small” … So no make sense have lower values.

And Stabilize Roll and Stabilize Pitch too “large”…

Is really difficult…to tuning , because I don’t have this config…but……Try to reduce from 4.5 the Stabilize Roll and Stabilize Pitch to 3.0, only to test.

Other important thing : do these tunings in stabilize mode first very close to the ground , after this you can switch do alt-hold….tuning And then pos-hold tuning.

What’s your propellers size ?

Do you tune them in alt hold and position hold while its in the air? I’ve been changing values, then testing it, then changing values, the testing it. Am I doing it wrong?

my propellors are 15x5.5

I don’t know if I’ve noticed a difference with the I and D in Rate Roll and Rate Pitch, but bringing it down to the .08 let me fly it. I’ll take it back up and see what happens.

Can I use the auto tune feature? Or are the motors too slow?

I haven’t touched the stabalize roll and stablize pitch, I didn’t know I should try to change those.

I’ll try these and report back.

Thanks!

Sorry about my poor English…

Step 1 (very close to the ground)
First you have to test and tuning in stabilize mode (sensor mainly used is Accelerometer), when everything is working fine Step 2

Step 2 (1 or 2 meters from the ground)
Test Alt-Hold (sensors are previous + Barometer) , when everything is working fine step3

Step 3 (1 or 2 meters from the ground)
Test pos-hold (sensors are Accelerometer + Barometer + GPS)

I never use auto-tune, but auto-tune works in alt-hold mode if I’m not wrong, but without step 1, you can’t fly, and auto-tune is useless.

Auto-tune is good for fine tuning, but I don’t like, 1 year ago, I have a “BIG” crash after auto-tune.

For slow kv motors auto-tune is not a good idea, you are right.

And try to “google” a pid config for motors with similar KV, is the easiest way to have a starting point.

So I finally got a day with lower wind so I can work on the drone again.

I reduced the stabilize to 3 and it definitely made a difference. I still don’t trust the entire drone yet so I think I’m going to risk it and use the Auto-Tune next time I can take it to a large open space.

One problem I would really really like to figure out is why it acts as if I am pushing the nose down as I’m taking off. I have to give it full throttle so it gets off the ground before flipping over. Once its in the air, it stabalizes back out and stops moving forward. This behavior is seen in the takeoff on the video I posted. It is more pronounced now though. Is there a way to fix that? I want to be able to have it take off straight up, not fly forward 5 to 15 feet before leveling out.

Where is the center of gravity on your frame? Does it match with the center of thrust?

How do I find the center of thrust? but I wouldn’t be surprised if this is my problem.

I am using one of those frames that aren’t the typical quad frame, but I’m not sure what I need to change to either make the settings know what kind of frame I’m using or how to readjust the weight of the drone.

This is the frame:

http://www.hobbyking.com/hobbyking/store/__69286__Quanum_Spider_700_Professional_Multi_Rotor_Frame.html

I made a quick sketch to illustrate where is the center of thrust. Assume that your motors create equal thrust. You need to make sure that resulting pitch momentum is zero when calculated from the center of gravity.

Simply balance the copter so that its CoG is exactly in the middle between front and rear motors.

I just checked. The CoG is slightly to the back. Wouldn’t that make it fly backwards first if that was the problem?

I haven’t gotten a chance to change it and test yet but I wanted to see what your thoughts on that were.