OPUS Aborted RS2: Collection interval was not one of the allowed rates

Emlid Reach RS2 OPUS submissions are frequently aborted with this message:

1020 1. Collection interval of the data file was not one of the allowed rates.
1020 The intervals that are accepted are 1,2,3,5,10,15,30 seconds.
1020 2. The time of each epoch is offset from one of the above intervals. The
1020 seconds epoch field must coincide with one of the above rates.

I believe the issue is that the RS2 does not have a tight tolerance for the logging epoch. For example, my logging rate was setup at 1sec and the resulting epochs were shifted from a precise second:

Start: 2019 10 20 20 40 28.0010000
End: 2019 10 20 23 59 32.0100000

The logging epochs are not precisely on each second, and drifted later throughout a logging period. I think this is keeping OPUS from accepting the file because the data are not precisely on each second.

I’ve tried logging directly to RINEX 2.11. I’ve tried decimating files to 30 sec using WinTEQC. I’ve tried creating RINEX files by converting the UBX file using RTKCONV to RINEX. It doesn’t matter how I create the RINEX file, OPUS won’t accept them.

Anyone else having this issue and know a way to resolve it?

Hi Chester,

Please make sure you upload logs recorded with 1 Hz update rate

The files I’ve tested for uploading to OPUS were collected at 1 Hz update rate.

Could you please send these logs to support@emlid.com? We’ll take a look.

I can confirm that uploading logs to OPUS collected on the RS2 at 1Hz for 1, 2 and 4 hours is hit or miss. Sometimes it works, sometimes it doesn’t. Most of the time it doesn’t.

As far as I know, Emlid knows about this and is working on a solution. In typical fashion, they will have it working in no time at all!

I use OPUS allot but i use a dedicated setup from CHC/Igage.

I dont have a RS2. i was skeptical the RS2 would work with OPUS but reportedly it does.

your error message is very specific and you appear to be pursuing a solution appropriately so ill just add in some things to look at if you have completely hit a wall.

  1. how long did you log data for? you can use OPUS in two ways. you can log data for 15min to up to 2 hours and submit as “Rapid Static” or you can log data for over two hours and submit to “Static”. they are actually two completely different computational processes.

Rapid static works but it has a higher fail rate than static (this is documented). I dont use it anymore unless something has gone wrong and i need to get another control point but i dont have 2 hours+ to spend.

  1. OPUS will only process on the GPS satellites to my knowledge, so get rid of the SBAS, glonass, etc. from your log file

  2. sounds like you should set the antenna to “none”, look down in the comments
    https://rtklibexplorer.wordpress.com/2019/08/24/dual-frequency-ppk-solutions-with-rtklib-and-the-u-blox-f9p/

by the way if anyone in the San Francisco Bay Area (USA California) has a RS2 and wants to compare it to a multi hour OPUS location please contact me.

1 Like

Tracy, thank you for your post I’ve already addressed all of them. Emlid has reached out to me and have some files for testing.

BTW I’ve had two successful OPUS solutions, but most have aborted with the error message stated above.

Processing the static collections manually to local CORS has good results.

Hey there,

We conducted a couple of tests with OPUS and RINEX data from Reach RS2 and collected some recommendations for log recording to prevent any issues with OPUS:

  • In the RTK Settings tab, choose Static Positioning mode, enable GPS only and set up the update rate to 1 Hz
  • Go to Logging tab and select RINEX 2.10 raw data format
  • Enable raw data recording and log the data for more than 2,5 hours. According to OPUS, it’s better to use raw data logged for 4 hours at least

We also recommend using the latest dev v2.21.1 version to log raw data on Reach RS2 as in this release we’ve fixed the issue with missing epochs in raw data logs and bug with some L2 carrier dropped during conversion to RINEX on Reach.

According to our tests, it shouldn’t affect PPP in OPUS.

I’d also like to point out that OPUS processes only GPS data. It seems OPUS can accept the logs containing other constellations as well, however, it can abort the processing in case the first epoch doesn’t contain GPS data. That’s why our general recommendation is to log GPS only for OPUS.

Thank you.

1 Like

Tracy,
I am curious about your comment about CHC/iGage setup. I use a surveyor friend’s igage ig3s on occasion and utilize RTKLIB and OPUS depending on the requirement. I looked up the CHC CGO2 and that software looks a lot like the Trimble Geomatics Office software that we used to utilize with our Trimble units back at my days with NYSDOT. Is that the case and if so I would really like to here your pros/cons with that software package?

David
With the CHC/IGage i just use the conversion and upload tool it comes with (free on thier site) that sends the data to NGS OPUS, then i get the single corrected point back via email.

i have not looked at the CG02 software except to notice that the price isnt bad at all. you should download the demo and try it and contact igage they are very helpfull. with the RS+ I use RTKLIB, reachview, QGIS, and a bunch of python code, thats my stack so to speak. i dont personally see a reason to look at something other than RTKLIB but i would love to hear about other tools folks use with their emlid products.

Tracy,
I am familiar with that upload tool from IGage also. Pretty slick and it gets the job done. I am going to look into the CHC CGO2 as I was an extensive user of Trimble Geomatics Office back in my days at NYSDOT and is a familiar software to me…And the price point is exceptional vs other baseline processing/network adjustment packages on the market…I’ll let you know what I find out.

Hello I have a RINEX2.10 file still .zipped straight from the RS2. It is GPS only static mode and logged for about 5 hours. I tried to upload this 40mb zip file to OPUS and go this error:
PROBLEM: OPUS doesn’'t recognize the internal format of your data file raw_202004230008.nav as RINEX, or as any format it could translate to RINEX.WHAT TO DO: translate your data file to RINEX yourself before uploading. Ask your receiver manufacturer for format conversion software, usually available for free.
Update: It reported an error but i nevertheless got an email with results.

Hi Nico,

I’ve noticed that you uploaded the .nav file to OPUS. OPUS usually requires the .obs file, could you try it instead?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.