Only one compass available on Navio2 and APM

Hi guys!
First of all, I’d like to thank everyone who developed this great hardware - Navio2. The board works very well for me.

The issue I’d like to resolve next is how to turn the second internal compass on. Currently only one compass is detected by ArduCopter. I guess that is the reason of frequent alert “Bad compass health” and related.
The drone flies quite stable in any GPS mode, but I am worrying what could happen occasionally having these alerts.

I installed all the software as listed in docs - linux image, apm-navio2 deb etc.
What should I do further to let APM to determine the second compass? Any drivers?

Would appreciate for reply. Cheers, Andrey

Hello and thanks for the feedback!

I’m wondering what makes you think that only one compass is detected? What GCS do you use?

Mission Planner 1.3.38 APM V3.4-dev

Have you tried Onboard Mag Calibration? You can also check if the second compass works using a Tuning tab and selecting mag and mag2 reports. It’d be helpful to know if there’s any data there.

1 Like

Where could I find the reports?
See screenshot

Eah, I tried Onboard and Live - both changed values for the first compass only. In Live Cal there are only first changes errors, others two are always 99. See here and here

Moreover, have dowloaded the logs, there is Sensors/Compass/Compass graph shows data only, other compasses 2 and 3 have no data

Could I check if an appropriate driver exists in Linux?

Cheers, Andrey

All drivers that are needed are already installed. Drivers for sensors are integrated into ArduPilot codebase so there’s nothing you need to adjust. Have considered a fresh install?

1 Like


using command sudo apt-get install apm-navio2 we actually install apm 3.4-rc1.
How can we install the unstable apm 3.4-dev ???

Thank you

Unstable version are usually left for advanced users. That’s why we don’t package them. You can either download one from here or build from source with instructions we provide in the docs.

Today I did installed the latest emlid image on the next recently bought RPi3 and Navio2, upgraded, launched Arducopter 3.4-dev (the latest ALF).
As in my previous setup only one compass is available in Mission Planner.

May be apt-get upgrade affects that?
Any ideas?


Could you please be so kind and and switch to the main HUD tab of Mission Planner, check Tuning in the bottom of the central pane and select magx, magx2 and so on. After that rotate your copter a bit and observe if values for both compasses change.

If they don’t change at all, please build and launch our examples (AccelGyroMag) and try it out with different parameters -i mpu and -i lsm and look at the compass column.

problem solved. Mission Planner started to read values from the second compass in several seconds after first. Going to make a clean deployment on the first Navio2 to get rid of this issue. Thank you.

I’m glad you’ve sorted it out!

1 Like