One RS+ unit not seeing WiFi, other one does

Hi, I have a problem with one of my RS+ units, where it simply just won’t see any wifi’s.
I have 2 units. One works perfectly (one that recently replaced due to another an seemingly unrelated WiFi issues), but the other just won’t see or connect to any WiFi. The list of wifi’s is simply empty, but on the other unit I see my WiFi’s and the neighbors just fine.

Here is what I have tried so far, all without any success:

  • reflashing the unit (2.14).
  • checking all password
  • connecting to a auto-switching 5g/2.4g network
  • connecting “pure” 2.4 and 5g networks.
    -checked all passwords for the WiFi’s.
  • connecting to my phone WiFi hotspot:

It seems like it is trying to connect, but for some unknown reason never succeeds. On my iPhone hotspot, the blue hotspot comes up for 1-2 seconds while the unit tries to connect, and disappears again.

What to do?

Neither one of my RS+ see 5g networks… Has the troubled unit ever connected?

Yep, has worked nicely up until now. As I also write, the other unit works just fine.

Hi Christian,

Sorry to hear you have another issue!

We are looking into it, I’ll get back soon.

Guess life shouldn’t be that easy, huh?
Hope it can get resolved, it’s pretty wierd this one.

Have you tried reloading the firmware manually? Master reset…

Manually? Master reset? Not sure what you mean.
I have reflashed the firmware according to the documentation. That also resets everything, as far as I know.

Hopefully Emlid figures this out for you Christian. ; )

I am confident they will!

Did Your devs have time to look into this one?

Sorry about that, poor choice of words.

Been there, done that, as I write in my initial post :slight_smile: Didn’t fix it.

1 Like

Ok. You’re not on 2.15? Is there a reason why?

Not considered a stable firmware, and no way to go back to 2.14 according to the docs.
I would also be confident that @dmitriy.ershov would have told me if this was already solved in 2.15.

So basically can’t risk it.

1 Like

From my experience 2.15 has been solid, but my use-case may be different. Not being able to flash back is very odd and unfortunate. If you have done everything mentioned in this thread today I would be almost certain that it is a hardware fault. I don’t think there’s anything else you can try with a simple function as this. I mean consumer Wi-Fi has been around for over 25 years. Does that make you feel old? It does me.

For me it doesn’t matter whether or not it is a hw or fw bug, as long as it gets fixed one way or another and fairly quickly.

1 Like

Hi Christian,

PM’d you some time ago. I hope we’ll be able to investigate the issue remotely.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.