One motor responding slower to RC commands

I took my Navio 2 powered drone out for a maiden flight on the weekend. I had done all the pre-flight setups and checked my motors were spinning as they should and the props are on where they should be.

On my takeoffs I would experience flips / roll overs. There is a video here that shows: https://www.youtube.com/watch?v=mMokRyuHsjo

I recalibrated my ESCs as I have been noticing my #4 motor is sometimes sluggish off the mark. No amount of ESC calibration seemed to change the fact that it is a split second off the others.
If I throttle up slowly and evenly the #4 seems to start at the same time. But, if I throttle up and down fast (twitchy throttle up, then cut to zero as quick as I can)- motors 1, 2 and 3 all start up and shut off fine. But my #4 never gets going. It seems slow so to respond to the RC inputs that it misses the starter’s gun entirely.

I suspect this has something to do with my roll overs and flips.

Can someone give me some advice about whether I can solve this?
My next trouble shooting step will be to swap motors to see if its related to motors or ESCs. I can only think my options are replacements. Would love to know if there is other options

Thanks in advance

It looks like both right motors are turning slower and slower, while the copter tries to take off.
Since your copter starts to roll to the right, the right motors should actually spin faster, to counteract the roll.
Are all inputs working in the correct direction? Did you try to manually apply roll input to prevent the flip?

This video is in slow mo. At real speed most of these flips happened so quickly I would have needed to be very quick to counteract them using roll or pitch. Once I got an understanding of what was happening I was able hold throttle just before take off, and if I saw a tip -then I would throttle down to prevent it. But wasn’t bold enough to try to counteract things.

This looks like one of the slower / roll overs rather than the flips which happened initially as I was powering up past take off throttle.
I only noticed when I saw this video that it rolled over to the right. In prior takeoff attempts it did a backwards flip. Ie, would roll over the rear motors rather than both left motors. When I saw the video I was surprised this one was more sideways rather than backwards. But I didn’t read too much in to that given it had rolled backwards previously.

In relation to checking inputs are working in the correct direction: are you suggesting applying pitch, roll and yaw and checking to make sure the right motors power up / down as you would expect?
Ive already checked to make sure that each output is attached to the right motor, and i’ve done RC calibration and checked my RC inputs are the right direction. What would cause Navio to power the wrong motors when trying to pitch, roll, etc?

Are you sure that propellers and motors are installed in correct way and rotate in right directions? Can you post pictures of that?

Thanks for the replies. They are helping me narrow down what is happening (I think).

Here is a video of several throttle ups of my drone. I did not take it to takeoff. I just wanted to check how motors were starting: https://goo.gl/photos/HcCjXyL3v9GF6MLK8
The first and the last attempts on the video are a steady increase in throttle. It looked like all motors start at the same time. Although motor #4 spins longer after shut off.
The other attempts show me pulsing the throttle quickly up, and then down to zero. You can see different motors start at different times with the #4 motor never really getting going in that situation.

Immediately before I filmed that video I did an ESC calibration. Immediately after the calibration the motors seemed to be starting perfectly in sync. But I kept powering up and down and each time I did that they seemed to become out of sync as if the ESCs were ‘forgetting’ their calibration. Odd. They are Multistar 20A ESCs flashed with SimonK

@Sebastian, I tried the hand test to identify whether or not my RC controls were having the correct input on motor power. I felt some unusual things:

  1. Roll was reversed. So left stick caused the quad to roll in my hands to the right.
  2. Pitch didnt really seem to do anything. I could tell there was an increase in power to the motors, but no noticeable forward or backward movement in my hands. As if the motors were cancelling each other out

That confuses me, because earlier I one by one unplugged the servo cables plugged into Navio and then powered up throttle. I checked that the expected motor didn’t spin. That gave me confidence that the motors were plugged in in the right order. Now I am struggling to explain what is happening.

Is it any use if I upload the tlogs? I am not sure what I should be looking at. Any suggestions welcome.

Other things that might be relevant:

  • I am using a Turnigy 9x Tx and Rx connected to a 3dr PPM encoder.
  • RC is calibrated to Mode 2, which is how my Tx is set up.

Any suggestions for where to go from here would help me greatly. Thanks in advance.

My yaw inputs seems to be controlling my motors pitch. If I yaw left on RC it pitches forward, and vice versa.
That’s why I couldn’t feel anything when I performed the hand test and tried to pitch forward but heard motor inputs. It is sending yaw instructions to the motors.

A bit confused because my RC radio settings in RC calibration are Mode 2, and I get the right responses in the UI here. The yaw inputs on my radio moves yaw UI, and pitch RC inputs moves pitch UI. So something is happening on the way to the motors it seems

From your video, it looks like all props are turning in the right direction and you do not have the props mounted upside down. I have a similar motor startup problem with my racequad. I suggest you switch ESCs, to see if the problem moves with the ESC.
From your description, it very much sounds like your ESCs are not plugged in in the right order. Check and double check. It is an error I see very often and it sometimes happens to me. If your radio setup is working correctly, it is a first step, but the directions of the RC input bars do not always indicate the right direction of the channel. As a general guideline, check if the stabilisation is working in the right direction, by holding the copter in your hands (if you are brave), throttleling up a bit and see if it resists movements/tries to stay level if you move it with your hand. If it instead “amplifies” your movement, reverse that channel in APM/Missionplanner. Second part would be to check if your inputs work in the right direction, like you already did. If you notice an input is working in the wrong direction, reverse it in your transmitter.

Although one of your motors is not as sensitive (though you should still be looking to fix it), it should not cause a flip.

Please read this link carefully:

http://copter.ardupilot.com/wiki/common-radio-control-calibration/

Even though you are in Mode 2, you need to make sure each channel is correctly mapped to what APM expects.

PS: To test your motor’s spin direction, there is a Test Motor tab in Mission Planner you can use. But in your case, you already have them in the correct direction.

Unfortunately I haven’t been able to make much progress on getting to the bottom of how to resolve my dilemma.
My RC inputs look to be incoming correctly to APM. I stepped through each input to be sure: https://goo.gl/photos/VzXmwH4GZYnLcrPc9

The hand test seems to indicate yaw and pitch channels are getting mixed up somewhere along the line.
The result is the same, a flip to the left on takeoff.

I had a look at the t-logs of my attempts to take off. And I saw nothing unusual in the RC inputs. Just a steady throttle increase - Channel 3:

I looked at the servo outputs, channels 1-4 to see what was happening. I am not sure if this is usual, but each output had outputs increasing steadily- but different ranges.


Interestingly, Ch2 and Ch3 showed a power up at the last minute before crash, but Ch1 and Ch4 power down. I am not 100% sure about whether RCOUT = power to each motor. But if motors 2 and 3 were powering up, and 1 and 4 powered down it would explain the rollover. That’s what I saw.

That would make me wonder why the Navio thought it needed to roll left so hard.
Can anyone tell me if I am reading these tlogs right?

Your mappings look correct from the video. Only thing I can think of is to swap motors/ESC around, to see if it flips from left to right. If so, you have a faulty motor/esc somewhere. Else, maybe a software bug.

Die you check that u used “x”-configuration in “frame type”? Did you check AHRS_Orientation value?

Did you check if your ESCs are really connected to the right outputs? You did say in one of your posts, roll was reversed during your handheld test.
What you are seeing in the tlogs, would be the result of it. The Navio/APM does not think it must roll. It tries to prevent the rollover, but roll is reversed. So instead of preventing the roll, it gets worse.
Follow the guideline I wrote before, or use the motortest option in Missionplanner.

1 Like

So, I had connected my motors in the sequence required by my KK board: clockwise from top left. So 1, 2, 3, 4
I had checked and double checked they were connected in that order.

When I Googled where to find the Motor test function in Mission Planner I came across this: http://copter.ardupilot.com/wiki/connect-escs-and-motors/#quad and I had a HUGE face palm moment when I saw the diagram that showed the sequence for a Arducopter is different: 3, 1, 4, 2 when going clockwise from top left.

As soon as I re-connected the servo cables in that sequence the hand test worked fine. I took it out for another flight attempt tonight and got it off the ground and flying nicely! Just got to do some tuning, fix some compass warnings in the logs, and maybe reduce a bit of vibration. But overall- so glad I am up in the air!

Thanks everyone for their help. Taught me to be doubly careful to RTFM

1 Like

This post was flagged by the community and is temporarily hidden.