Obtaining Fix position after v0.4.9

After upgrading both Reach devices to v0.4.9 we are unable to get a fixed position with our old setting and even the default settings in the ReachViewApp. I have tried moving to different location, changing setting, running just over wifi, and even set up on the roof of a building to ensure zero chances of sky view obstructions.

Satellite coverage on most locations with very little fluctuation in location over 30 minutes.:

Reach settings for both units:


Rover:


Base:

Is there anyway to downgrade back to v0.4.7 as we were having a lot of luck on that version? Also if someone has any ideas on what else we could change that may help. I went through the advance settings and tried some changes with no luck at all.

Ian

please make also a photo of advanced settings.

try to switch dynamics "on"
base antenna coordinates to rtcm3

in advanced settings:
gps mode to "fix and hold"
glo mode to “off”

in base switch on rtcm3 messages on - according to where you live…

Hy

I try “all” combination but with the new update I’m not able to obtain fix position in static mode. I’m not an expert but it seems that I’m not able to receive the RTCM correction from base station

My configuration that works perfectly in kinematic mode is gps only and I set up to receive the message from base station using ntrip.

can you help me ?
thx

Francesco

Yes. All old versions are actually on your Reach. Enter the /home/reach/ReachView directory and type git tag to see the available versions. Pay attention to the contents of the update.sh script as it contains some copy commands to update RTKLIB binaries and default configuration files, plus a chown command to fix permissions. Don’t forget to kill the server.py process first and start it again (or reboot) when done.

Hi Lan.

I do not have solution for you, because I have some similar problems, but, I would like to get the level where you are, because I have 2 radios 3DR and not achievement make the basis to send data to the rover.

Could you send us some picture about the way you connect your Reach modules to radios?

Thanks.

First off thanks for everyone’s response. I have tried all from above with no luck still.
@Andreas_Ortner
Rover Settings:











Base Settings:

@bide
I will try downgrading as a last resort. Thanks as always for the help

@Francesco_sisani
As soon as I come up with a solution I will let you know. How are you having the reach devices communicate (3DR radios, RFD 900+, wiki, …)?

I do not have the option for rtcm3 under base antenna coordinates. I do have rtcm which I think is the same thing.

@Jorge_Cano
Go through the list below and make sure all of your settings are correct.
1.) 3DR radios are paired and have all of the same settings. The best way to check would be to use mission planner> Initial Setup> Optional Hardware> Sik Radios. Make 100% sure everything is matching and nothing is checked off that shouldn’t be.
2.) Unsure all of your connections are correct on the reach itself. The radios should be plugged into the DF13 port on the same side as the USB port on the reach. The other side should be only used for powering the device I believe.
3.) Look over my old post and make sure you settings are correct for everything. I have a picture of how things should be plugged in. Stand alone Reach - RFD900 Config
4.) Check to make sure both reach devices are up-to-date (orange arrow) by clicking the gear (red arrow) picture on the top right of the screen when you are connected to the reach device via a web page.

Oddly enough, as I was typing a response to everyone on the post I had the pair of reach devices running outside the shop. In that time the rover gained a fixed position and everything seems to be working some what. If anyone sees any settings that should be changed please let me know. It took about 25 minutes to gain a fixed position. As promised from one of my other post I will take pictures and document all settings so others can avoid the confusion themselves.
Reoccurring Problems:
Latitude and Longitude hold position out to about the 5th and 6th decimal place respectively while the height fluctuates up to +/- 1 meter constantly. I have a feeling better antennas would help out but still worry about data accuracy in the end.

Please write back with any tips and or questions as I am around the forums a lot watching what people come up with and trying to help out when I can.

Ian

Hy guys
I tried to explain my configuration

I can receive the correction from base station using ntrip connection (internet no radio) and this config works perfectly if I set my reach device Kinematic (I use my samsung s4 as hotspot wifi) so my doubt is probably the rtkengine doesn’t work if I setup my reach as Static

I hope my expalnation is clear enough thx for your support

Francesco

@Francesco_sisani
I believe Static is to collect data on a single point, not moving the reach device at all, over an extended amount of time.

A good example would be if you are wanting a ground control point and need to know the exact point to a very high level of accuracy. You would set your reach device in Static mode and leave it there for as long as possible and then import the data into RTKLIB and process it to obtain a very accurate position for that point.

What are you trying to do with your reach and what is your goal?

Hy Ian
thx for fast reply

My goal is to set up my reach device on top of my roof like a base station but I don’t want to obtain the fixed position with post processing but in real time using the correction provided by another base station… I know that this workflow isn’t “rigourous” (no double frequency receiver no geodetic antenna ecc ecc) but I’m interesting to evaluate the performance oh this kind low cost receiver to “built” a network (like pylongps project) …maybe also to try to add my base station to the "professional " network

… sorry for my bad English …

Francesco

@Francesco_sisani
You would be better off starting a new topic and outlining exactly what you are trying to achieve in the end. Im focusing on RTK for UAV’s thus using radios. It sounds like you are trying to create a virtual network or at least tie into one. I think someone has posted almost exactly what you are trying to achieve. Ill go back and look to see if I can find the post for you. Sorry I cant help much on your topic as I have not messed with connecting directly in other base stations while simultaneously running my own base station. What country are you located in so I can see if there is already a solution for your question?

Hi Ian.

I´ve verified my connection between radios through Mission Planner and it seems everything is OK (I send you a screenshot), but when I unplug the 3DR radio from my PC and connect it to Reach Module, apparently connection is damaged.

Thanks.

Hi Ian.

According to your recomendation, I´ve verified my version and I checked that both are updating to v0.4.9.

What else can I do?

Again, thanks.

HY Ian

I live in Padova (ITALY) and I use this service forn ntrip correction http://147.162.229.63/Web/index.php

Sorry but I forgot to mention that with old version of rtknavi (2,4,2) I’m able to get fix coordinates now with the latest 2.4.3 b22 not

thx
Francesco

Hi!

I think i have a solution for you!

You are using 4.9 with your old config file kinematic1. Emlid has moved to latest beta.

What you can do:

Update rover again.
use Reach_default_kinematic from emlid
update file for your connection setting:
change only following settings:

try to switch dynamics "on"
gps&glo 5hz

in advanced settings:
gps&glo 5hz - according to your base settings
gps mode to "fix and hold"
glo mode to “off”

stay at fix position for fix

After leaving the shop yesterday to go test the setup in the field I could not gain a solid fix lock. I think it has to do with the RFD 900+ radios not sending/ receiving the correction data fast enough. I kept having the gray bars, base correction, drop out randomly while in the kinematic mode shown above. At the shop I am viewing the reach devices over a wifi network and am pretty sure the devices are using the wifi to communicate even though I have the radios set to send and receive the data. Today I will try adjusting the RFD 900+ radio settings and also try switching to xbee and 3DR radios to see if I get any better luck.

@Jorge_Cano
Reach + RFD900 radios
Look at Juan’s first picture in that post to see if those radio settings work any better for you. Hopefully something in that picture when compared to your settings will lead to a break through. As mentioned above, Im going to try different radios today in hopes of finding a solution to get fixed while off of a wifi network in the field. We are trying to set up our reach devices on an aircraft and base station for precise photo geo-tagging so wifi isnt really a viable option for us. As soon as I find a solution I will let you know.

@Francesco_sisani
http://pylongps.com/doku.php
You have mentioned pylon gps and the link above dives deep into the setup of this type of project. I have not looked into it much, but they seem to be the guys to talk to. What you are trying to achive doesnt sound to hard since you are not moving around and can connect to a wifi network fairly easily. In the US where I am we have CORS sites that continuously run and correct for their positions spread out across the country. After looking int Europe and Italy especially I have found a similar project here: http://epncb.oma.be/_networkdata/stationmaps.php. You have an operating station fairly close ( http://epncb.oma.be/_networkdata/siteinfo4onestation.php?station=PADO00ITA ) to you which I believe to be within a 10 km range of where you are testing. This is good because once you get your reach device running you can use RTKLIB to verify that the data you are collecting is accurate. There are several tutorials both on the forums and under the reach documentation that walk you through the steps on doing so.
Reach Document Tutorial: https://docs.emlid.com/reach/gps-post-processing/
Run through the first part of that tutorial where it discusses the base station as you will not need to go over the rover part. Sorry I am not much help on the setup going over ntrip.

@Andreas_Ortner
As soon as I get to the shop I will try the settings you have recommended using the default_reach_kenimatic.config
We have ordered an adapter and plan on stepping up to a heftier antenna in hope of obtaining better satellite coverage. I think our main problem right now is that we are using a wifi network along with RFD 900+ radios in the shop to view the reach devices and only using the RFD 900+ radios in the field. I know @bide has covered the 900+ radios extensively in the past and will probably have to go review his past post to see what kind of settings I need to chance.

I will post any findings I get and will end up making a post on how to setup the reach devices when I have a better solution.
Glad to see everyone helping out on the post and as always thanks for all of your input.

Ian