Hello All

I have been trying to get Ntrip working. Finally have the base outputting data to RTK2GO.com and the rover is getting the data, but this is all on the same wifi connection to the internet.

I have connected my iphone to the rover by bluetooth and they both say they are connected. So far I have not been able to get this working properly. When I connect my ipad to my iphone the hook up shows on my iphone as 1 device connected and the menu bar at top is blue. I do not get this when reach is connected.

Any one had an iphone used as a hotspot for reach? Any info appreciated.


I am assuming (from your 1st paragraph) that you can see the changing gray color bars on the Status page of the REACH’s web page interface (indicating that you are getting the NTRIP corrections). I have an Android phone and I don’t see why an iphone couldn’t function as a hotspot (unless restricted by your cellphone provider). Is there a program on your iphone to get the NTRIP corrections and send them over Blurtooth to REACH? I am using NTRIP Client on my Android phone. Bluetooth is just a link, you may want to setup TCP/IP on the REACH in order to get the NTRIP corrections itself (just connect the REACH to your iphone hotspot).

yes it is working on reacview.

I have my rover reach connected to my iphone on bluetooth, both the reach and the iphone say they are connected.
I also tried to use my phone as wifi hotspot but it does not work either. Too bad as very good signal and fix thru this setup.


I probably wasn’t clear, forget about connecting REACH to iPhone via Bluetooth. Verify your hotspot is working and connect REACH to hotspot. Go to ReachView “Correction input” page and select either NTRIP or TCP, in order for REACH to receive the corrections from internet. You cannot select Bluetooth because you don’t have a program running on your iPhone in order to get the corrections from Internet and send them over Bluetooth to REACH.

1 Like

Good afternoon

Ok that makes sense for the blue tooth as it was showing as connected on both, but of course no program to use.

After several attempts I got my iphone hotspot working and got my reach connected.
I am going out to see how it works now.

Thank you for the help James


Hello All

An update to my iphone as a hotspot…it worked once.
The next time I tried to use this reach module I was unable to find it on fing…It took me a long time to discover it was on fing but listed as “mobile Apple iphone 5s” I signed into it and seemed to work fine so updated it to new version 2.6.0. It seemed to update fine but when it rebooted it came up to a flashing yellow light, never did get to log in it did not show up in fing at all… After several hours I reflashed the unit and updated it to 2.6.0… Funny thing it works but is still showing up in fing as an apple iphone 5s? Ok I deleted fing and reloaded on my phone and it shows that unit properly now as a murata.

As another point in the documentation it says:
"Network scan¶

Reach will indicate a network scan with yellow blinks. If a known Wi-Fi network is detected, Reach will connect to it and set the LED blue. If the scan found no familiar networks, a hotspot is started and the LED will light green."

For all 4 of my units a solid green light shows when a known wifi is found not when its own hotspot is started?

Thanks Jim