NTRIP Rover Location off by ~20ft

I am working on getting the Emlid caster setup. However, I am encountering a few issues.

The Setup:

  • Emlid RS2 as base
  • Emlid RS+ as rover
  • Retrieve fix from CORS network and average base
  • Setup NTRIP base output from emlid caster mount points
  • Setup NTRIP correction on rover
  • NTRIP Connects and rover gets a fix through Emlid Caster

The Problem:

  • Base and rover are a couple feet away from each other but it shows baseline as 19km
  • The rover has a fix but it is ~20ft away from the correct location.
    • I tried different coordinate systems when setting up a project but that does not make a difference.

Any help would be appreciated.

Why not just use the RS2 as Rover with the CORS base and take the RS+ out of the equation?

How far away is the CORS?

Why average the RS2 Base?

Hi! Thats what we have been doing but the CORS network in our area has been going through some changes and has decreased in reliability. We want to bring it in house.

Hi Andrew,

First of all, thanks for such a detailed description of your workflow! It’s always of great help for troubleshooting when we get such thorough info.

To me, such behavior looks like something went wrong with the base position setup. So I’d really like to clarify the steps of the base setup in more detail.

Did I get it right you averaged the base position while being fixed? How did you save the base coordinates?

Just to double-check if there is any issue—if you average the position in Single, will there be the same wrong baseline in 19 km?


Thankyou. I did try it a couple different ways with average base on single solution. I will try it again with another unit and get back to you.

Okay, please keep us posted!

Shouldn’t you be setting the base on your fixed point, then from the base get the corrections from your CORS? Record the those coordinates. Plug them into the base as a known point still set up on your fixed point. Then use your rover getting corrections from your base, eliminating the CORS now?

When you average the base (instead of using accurate known coordinates) it’s offsetting everything there on out.

1 Like

Tried again this morning with a different Emlid NTRIP Caster stream and it is working. Not sure what was going on yesterday. :man_shrugging:
Thanks for your guidance.

1 Like

I don’t have a known point, so I am creating the known point for base from the CORS network and then eliminating CORS. I got it to work this morning so not sure what happened yesterday.


I see you’ve resolved your issue but I just want to confirm details of your workflow for obtaining / creating your own “known point”.

  1. You set your base up and initiated logging for that position for something like an hour (or whatever period of time).

  2. You took the observation file and ran PPK on it using a CORS base to obtain an “accurate” coordinate for that position OR you used OPUS static processing to obtain an accurate coordinate for that base.

  3. You then took those coordinates (E.g. lat, long, ellipsoid) and manually enter it as your base coordinates; thereby creating your “known point”.

I ask because you didn’t really go into specifics with regards to how you were obtaining your “known point” and this is likely where the issue would be identified.



1 Like