NTRIP mobile data connection

I’m having trouble getting my base to stay connected to NTRIP Caster through the internal modem with T-Mobile. It either drops connection briefly, requiring me to reconnect to the mount point, or disconnects entirely so that I can’t get any corrections at all. It often says it has no mobile data at all even though I should have coverage, even minimal, everywhere I’m surveying. I’ve tried restarting the base, turning off and on the mobile data, updating the base to the latest firmware, flashing the base to firmware 30.0 (when I know it worked well), removing and reinstalling the SIM, changing out the SIM for a new one, changing out the receiver for a new one, and repeating all those things with the new receiver, and more. The problem has occurred in rural areas as well as city and has been going on for weeks.

May or may not help…


I’ll try it out but I have my doubts that it’s the network only.

Hi Jared,

Sorry that it’s so quiet here!

Could you please generate the Full system report on the device when you spot this issue again? It’d be helpful to check the modem logs to see what was happening there.

Please also check whether the base stays or not Online on the Caster page when this occurs. It’d also be helpful for narrowing it down.

Thank you for turning me on to Eiot Club! Their SIM and plans work great and are even cheaper than T-Mobile.


Thank @ryan.gay2013 ! ; )

1 Like

Glad the new sim card worked out for you Jared!

1 Like

The problem resurfaced today. I sent you a message with the system report. Let me know if you find anything. I think it has something to do with firmware 31.

Hi there,

Just wanted to write an update here that we were in touch with Jared regarding this issue, and it turned out to be related to the intermittent cell coverage on site.

If you face anything similar, feel free to create a new thread or contact us via support@emlid.com.