Non-responsive RC Input in Loiter Mode

Hi all,

I finally got rid of my EKF errors! Woohoo. So, I went out today to test a few things (Loiter being one of them). When switching into Loiter the quad would start to drift and the RC yaw, pitch, and roll (possible throttle) inputs were unresponsive by the craft. That is to say, the quad did not respond to my inputs – at all. I tried a few times, but to no avail. I have attached the df log below. Taking a look at RCin ch2-4 and RCout ch2-4 shows weird results where the quad was in loiter.

Example: RCin ch2-4 drops to the min PWM value when any stick movement is applied to the RC in loiter mode. See screenshot.

Also, the DVelX vs. VelX (and DVelY vs. VelY) show weird things. See below. Image one is from a normal Loiter’s log. Image two is from the attached log. What’s also weird is that the DVelX (and Y) and VelX (and Y) do not encompass the entire flight log… Huh?!



Also, for shits and gigs I tried a short auto mission, but the error “No takeoff command given”. Of course I had already taken off and was in the air. Note that I have flown this exact same auto mission in the past – it’s just fly to a few waypoints. I’m quite confident they are related.

Anywho, any thoughts on this?

Austin M

Loiter_Issues.BIN (6.1 MB)

EDIT: Confirming this worked.

Appears to be solved here. I’ll try this tomorrow.

1 Like

I’m curious, I did not see the MOT_THST_HOVER parameter in MP; is there something that I am missing?

What version of ArduCopter are you using? It’s there in 3.4-rc1.
Austin M

I’m running 3.4-rc1, and in MP all that I can see is MOT_THR_MIX_MAX, MOT_THR_MIX_MIN & MOT_THR_EXPO.

Did you compile, or use the “standard method”? Note that I built 3.4-rc1 from source.

I went with the “standard method” as described in the docs section. Right now I’m working with the 3.4-unstable, getting everything configured for a few test flight tomorrow morning. I’m hoping to find a variance between the 3.4-rc1 and 3.4-unstable to account for this odd behavior. So far so good, and if all goes well tomorrow morning, then I’m going to be sticking with the 3.4 unstable until the bugs are acknowledged and resolved in 3.4-rc1, and transplanting the Navio 2 from my F550 to my Quanum Spider 700.

Everything was working just fine for me until 3.4-rc1… Damn you 3.4-rc1! Damn you straight to hell!!! :wink:

Weird indeed. What issues were/are you having? Especially as it relates to the above-mentioned solution.