No wifi in the field? Setting up the pi as a router for direct connection

Have a problem in that I can’t connect my my drone in the field via ground control without a wifi router and ac power. Makes my drone pretty useless atm.

Looking for solutions for connecting to the rpi3 directly from a pc wifi and the pi 3 wifi. Just need to make changes in the field via mission planner.

I’ve not found any solutions for the pi3 directly and mostly outdated and messy looking ones for the pi2. I did just find this this script for a pi2 for those out there with a pi2. It seems a very easy solution if it works with the emlid build.

Here’s a direct d/l link to the script that installs it.

If anyone has a solution for the pi3 I’m all ears, I’ve searched and have found nothing. Pretty essential stuff for working in the field witouth ac power I’d have thought. As we’re unable to connect to the pi via usb. Can’t change any parameters or flight paths without a router. Or am I missing some a way or connecting to mission planner in the field.

Thanks

I have setup my rover and my tracker to provide their own wifi. It was really easy with the rover which runs a RPi 2 and a ralink based wifi dongle.
I tried to do the same with the tracker and a RPi3.
Using its onboard wifi, I had nothing but problems.
Sometimes the AP seemed to be working fine, but most of the time, the connection broke after minutes or even seconds. The client was still connected, but no network traffic was going through. No ssh, not even a ping.
I then used the same ralink based dongle as in the rover and everything is working fine.
My tracker now has two usb wifi dongles. One connects to the rovers AP with a directional antenna, the other one provides a wifi AP for GCS devices to connect to.

Edit: Both are technically routers with IP forwarding and DHCP server not only an AP. It would be easier to make the tracker just an access point/repeater, but creating a bridge device with two wlan devices just brought up to many other problems, so I stayed with the two router solution.

Think i get it. The tracker is an antenna tracker tracking the rover? The tracker taking data from the rover using it and relaying it to the GCS with one wifi dongle was the problem. So you think that the problem was due trying to bridge two wlans (you have three wifi trasmitters two networks inc the GCS).
Sounds like setting up a single AP to connect to for my usage shouldn’t be a problem. Have any tips or guide you followed?

Brilliant. My answer is gone.
Again in a short version.
Yes it is an antennatracker.
The Rpi3 onboard wifi gave me problems everytime I tried to use it. Be it as a client for the rovers wifi or in host mode as an AP. I always used two seperate wifi modules on the tracker and never tried to run the onboard wifi as client and host at the same time.
For final usage it would not make sense for me to use the onboard wifi as a client, because I can not attach my directional antenna to it. I configured it as a client during testing to see where the problem lies.
You can only hope that the onboard wifi of your RPi does not misbehave. In any case the range of the onboard wifi will not be great though.
I followed a guide on a german website, but any guide for raspbian jessie should work. The only thing that is really different To wheezy, is dhcpcd, the DHCP client deamon. All network config is done by this daemon now, so if any guide tells you to enter a fixed IP in /etc/network/interfaces it won’t work without additional configuration.

Sorry for my late response here. In order to set up new router or find out exact IP address this article can be helpful http://19216811.guru/

watch this video. Your AP is setup on the PI in the raspi-config menu. You will never need another guide again :slight_smile: