No USB output after update

Hi, I updated the firmware on my Reach M+ from 2.20.something to the newest version, and now I am not getting any positional output with the USB-to-PC option.

Before the update, i would simply “cat /dev/ttyACM0” and I would get the messages, after the update, no messages are appearing. I did not change any settings, and I tried to reboot the device a couple of times, nothing helps.

I also tried to update to the dev version, that did not help either.

Any suggestions? What am I doing wrong?

Hi Dan,

May I ask you to post the screenshots of your configurations and your hardware setup photos? Just to exclude any possible issues with that.

Also, could you share the output of dmesg | grep -i tty?

Hi, this is the output of dmesg | grep -i tty:

[    0.020225] ACPI: SSDT 0x000000006FFAB000 0004FC (v02 LENOVO TbtTypeC 00000000 INTL 20160527)
[    0.241098] printk: console [tty0] enabled
[   20.108441] Bluetooth: RFCOMM TTY layer initialized
[  367.637984] cdc_acm 1-1:1.2: ttyACM0: USB ACM device
[  557.143198] cdc_acm 1-1:1.2: ttyACM0: USB ACM device
[  776.369863] cdc_acm 1-1:1.2: ttyACM0: USB ACM device

I have recconected the device a few times, so it is showing up multiple times. This is the SW configutation:

And here is the HW configuration, I have just the antenna, USB cable and LoRa for corrections (disabled for now).

Hi Dan,

Could you please also share the screenshot of the Status tab? I’d like to make sure that Reach has at least Single solution status as it’s required to define and output the position.

Hi, yes indeed I did not have a GPS fix as I was indoors, now that I am outdoors I get the output.

This seems to me like a downgrade, on the older firmware version, if the unit did not have a fix, it would still send the messages, just full of zeroes. Now the unit sends nothing, if it does not have a fix. With the older version, I could tell that the unit is working, just waiting for a fix, now I do not know what the status is, as it does not send anything.