No trigger events via hotshoe adapter

I connected my Sony A7R with the Reach modul via a HotShoe-adapter, so that the camera triggering is indicated as event in the Logile of Reach. That works already partially. But have a strange behavior with the hotshoe adapter.

The event is only noticed, if a flash is additionally connected on the hotshoe adapter.

This is my adaptor: Look here at Amazon

It also works with this remote trigger for external flashes. Look here at Amazon
But only if the device is turned on.

Can anybody give me a tipp what I have to do, to get it working with a lightweight hotshoe adapter?



One option is that it depends on camera settings, try to tweak the flash configurations in camera menu.

Hello Igor!
Thx for your response.
I have tried all the flash settings of the camera.
Unfortunately without success.

Hi Christian,
as Igor mentioned it could be that the hotshoe is deactivated somehow, but I am pretty sure it isn’t (not a Sony user though).

Do you have an external flash so that you could check if that one fires?

I have a similar problem as you have with my Fuji X-E1 (same adapter btw.):

  • a Nikon flash works on the Hotshoe itself in manual mode
  • The same flash doesn’t fire if I use it with the adapter and a pc sync cord
  • no events are triggered on the reach
  • Events are triggered if I manually close the contacts on the reach cable or PC sync cord I use

You could also check that in your case. In my case I am pretty sure the adapter which is not working as it should, but I haven’t had time to buy a new one and try it.

PS: I just remembered that Sony/Minolta used to have a different, non standard, hotshoe. Maybe there is still a problem with contact alignment in your case. I am thinking of a 3d Printed plastik plate to slide into the hotshoe. All you need is the center contact (+) and the metal brackets (-/GND) of the hotshoe. The rest is communication pins you don’t need to trigger the reach module.

Hello Sebastian,
I have ordered various adapters at Amazon and there wa r then one of them has worked with my Sony A7R. That was my solution …

Great and thanks for the response. I expected something like that…

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.