No throttle with navio2 in channel 3

I tried the following on my fixed wing UAV: I connected the throttle ESC straight to the receiver and it works but doesn’t if connected to my Navio2 flight controller. Sometimes, it just beeps rapidly and continuously until I remove the battery, but sometimes it doesn t do anything. Do you have any ideas how to start my brushless motor in channel 3 from Navio2?

Thank you,

Hey there,

Was your UAV armed when you had the issue? Have you read the ESC datasheet?


I managed to get it armed because i set the ARMING_REQUIRE to 0,ARMING_CHECK to 0 and it’s armed at startup. Holding the stick for arming and disarming doesn’t work nor the arm/disarm button from flight data as i get an error that command is rejected by mav.

I cannot start the motor. With stick at maximum throttle i have power output to motor but it’s not spinning.

When i touch the motor it feels like it’s not powered as it is not hissing nor putting up some resistance(the battery is fine as motor works when connected to receiver):

Thank you,


Could you please try to run the PWM Output python example from our docs with the motor connected to the 3d channel to make sure it’s alright?

Before it please change the string PWM_OUTPUT = 0 to PWM_OUTPUT = 2 in the python script.

Have you checked the other channels? Is the 3d channel the one that doesn’t work?

I notice you have 1900us for max PWM on output channel 3. I guess min PWM is set to 1100us for this channel? If so, try to lower it to 1000 ( or even 982, like the PWM input value). Most ESCs will not arm themselves if the PWM signal is too high. Some beep to let you know something is wrong, some just do nothing.

1 Like

This worked. Thank you both!


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.