"No Solution Data"- But I can't find the problem!

Hello I am using a Trimble R10 as a rover and the Reach RS+ as a base to get ground control points for a photogrammetry model. The base (RS+) logs the entire time (5 hours total) while each ground control point gets a 5 minute residency time with the Trimble rover. In post processing, I convert the rover T02 files with Trimble’s “Convert to Rinex” software (I use Rinex v3.03 but can choose v2.10, v2.11, v3.02 or v3.03) and use the Rinex (3.0?) strait out of the Emlid for base data in post processing in RTKPOST. I use the settings in thebasic tutorial except used static positioning mode instead of Kinematic. I also use the NRCan ppp service to get a fixed position of the base which I input to the position tab for the base. When I hit execute then plot- I get nothing on the plot and the message “No solution data” on the bottom of the plot. I just cannot figure out what the problem is!!
Here are the screenshots of the process within RTKLIB. I have put two rover points worth of data along with the base station data including the NRCan report in Dropbox here





I very much appreciate your help!

try using the reference data of the rinex file in the positions window


Does not seem to matter what I choose in the position drop down…I’ve tried all of them. When I choose the XYZ option, It enters something close but not identical to what is in the Rinex header (see capture of Position Tab below). Still comes back with “No solution data”. Does my Rover Rinex header look right?


you have to choose the last box
Read position ro rinex

My last choice in that box is “RINEX Header Position”. Still no joy. )-;

Tried it- still didn’t work. Here is the data-

I’m trying with point number 2.

1 Like

Hello Paul, I do not understand much about RTKlib but I am learning, with difficulty because of the language. I hope I have helped

Thank you so much for trying! I think I have to reframe the question- I don’t think this is a Trimble problem- I think it is a data problem. I will see if I can edit the title.

Hi @green.cosmos,

I’ve processed your logs. The problem is that Trimble RINEX doesn’t fit RTKLIB as it is.
In Options-Settings1 tab you need to set Elevation mask to 0 and turn off SNR mask.
Also, you can set your base position manually by using coordinates from your NRCan- 201808131650.pdf file or use averaging.

Here’s the result for your 35.18o file. Regarding 2.18o, there’s no fix solution.

1 Like

Ha! Amazing thank you! I would have never figured it out alone! I think I may be missing another option here- my output ends up being a single point (with error and STD =0) as opposed to a cluster as in your work. What am I missing?

So - just to put a finer point on this- It would seem you can indeed include an elevation mask… and even an SNR Mask on the base (Emlid) but not on the rover (Trimble) data. Also in the file 2.18o, I removed the Glonass satellites and low and behold I got a fixed solution! Not sure how less is more here- anybody?

*also still interested in why my output is simply a point instead of many points as in the work above…

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.