No Sats

Been having a lot of trouble recently with the Navio picking up sats with the GNSS receiver. 90% of the time, I get GPSSTATUS: 1, No. SATS: 0.

After reading a few other posts with people having similar issues, I have connected up to the RP with U-Center, to investigate what is going on.

The first few times of running U-Center, Navio picked up sats and a position. I then killed the service through SSH, connected up with Mission Planner, and Navio was able to pinpoint my location, but it seems very hit and miss, and probably only works 1 in 10 times. Nothing has been changed, and I have done my best not to touch any of the connectors, in case it’s a loose connection.

Below is an image of the setup:

Also attached, logs from U-Center, one with Sats Detected, one with no Sats. (137.8 KB)

Any help would be greatly appreciated.

p.s. As powered in photo, sats are detected, and there is a GPS fix.

Is that an RPi camera connected? It is very noisy if the camera itself and the cable are not shielded and can affect GPS performance drastically.

It is a FatShark camera, using a 5.4 link (transmitter on front of quad). Thank you for the suggestion.

Please try to unplug some of the equipment and check if it has any effect.

Apologies for the late reply.

I have unplugged all equipment on the Navio to eliminate any possibilities of interference. I have also tried picking up sats with the Tallysman multi-GNSS antenna. The first time this was connected, sats were detected after a few minutes. The original antenna was then connected, and sats were still available. After a power cycle, again, no sats detected.

As mentioned previously, u-center data is attached to post. Navio seems much more likely to pick up sats after u-center is run on RPi, then disconnected, and a connection to Mission Planner is made… This to me, makes it look like Navio software is either slightly flakey, or something needs to be triggered for sats to be detected as nothing else is being touched during this testing…

Yet again this morning. 8 Sats picked up on first power on. Then as an exercise cycle the power (nothing touched in the 20 seconds whilst this is happening), and no sats!!

Very frustrating!


We were not able to reproduce this issue in our tests. Could you please try to make an image of your SD card (from setup where error occurs), zip it and upload somewhere? We will try to see if certain configurations result in this behaviour.

I will upload an image this evening.

Same thing happened again today. Seems like sats will work after a while of the RPi/Navio being un-powered. Then after a power cycle, it loses all sats.

Currently just bench testing RP/Navio with antenna & no auxiliary equipment to rule out interference.

Thanks, if you could try to separate most critical factors that cause the error that could greatly help us with debug.

Image available on the following link:

I have since done a fresh install using the latest and greatest and am still having the same issue.

Thank you, we will try to find the issue and will get back to you.

I had similar issues recently. The copter with Navio2 started showing no sats found despite it being in a clear area. I followed the suggestions made by Sebastion in this link:

In particular I set:
GPS_GNSS_MODE 69 (default 0)
I’m in South Africa so chose this for Glonass, GPS and Galileo. It is and 8 bit field so work out which bits are on - they are described in the parameter tree view in Mission Planner. Then convert binary to decimal.

GPS_SBAS_MODE 0 (default 0)
We don’t have SBAS nearby so I wanted to ensure it was not trying this. [Sebastian had it to 1 for his area.]
This forces the uBlox GPS rather than trying to autodetect.

After these changes I am getting 15 to 17 satellites and HDOP is consitently less than 1.

Hope this helps…

Good morning Rodger, and thanks for the response.

I tried the suggestions in your post, but alas, to no avail. Tried a few different combinations of GNSS mode, but no improvement. The only slight difference, is that I am getting no sats picked up on the Navio at all. When looking at U-Center, a fair few are picked up, but the fix only lasts a split second (probably best viewed in the logs - terrible explanation).

Hoping to get this resolved soon, have an 800 quad sitting on the bench waiting ready for a flight controller!

Pity! Sorry to hear that!

Feels a little like a hardware issue. Hopefully the guys at Emlid will figure it out!


Hoping so, have heard nothing but positives from people talking about the guys at Emlid, so have high hopes that they’ll come up with a solution!

@snsi I tried your image, but couldn’t reproduce the issue - always getting 3D fix. Please send an email to with your order number and link to this thread and we’ll arrange a replacement for you.