No RTK connection between rover and base

I’m having difficulty getting any kind of connection between base and rover.

Here’s my setup:

  • both units connected to home network ( and
  • both units using reach_image 1.2 and latest (0.2.2) Reach View version
  • Both units get a decent number of “green” satellites in single mode - I switched the setiing “u-blox configuration file” to be “GPS_GLONASS_5Hz” to get this, since “GPS_10Hz” didn’t get me as many. However - lest you think this is the problem, I was unable to connect rover > base with this config either…
  • I have the base set to “GPS_GLONASS_5Hz.cmd” since I figure this should match the u-blox setting for the rover…
  • I do have the “tcpcli” address and port correct for the base
  • I have checked with telnet that there is broadcast traffic from the base ip at that port and yes there is - no nothing in my network appears to block it…
  • I’ve tried “static” and “kinematic” modes for rover (since it is sitting on a stool on the front lawn after all…) but neither helps.
  • I have tried swapping rover for base functions between the units but that doesn’t help

Things that do work: I can get NMEA output from a single unit over bluetooth to android (great feature!), and LLH to RTKPLOT as well.

However - I don’t get the color beside grey bar view showing rover/base signal strength ever, and the rover says “single”

It would be nice to be able to get some feedback from somewhere in the program to know what the problem is… Maybe it is something really simple!

Anyway if anyone has any help I’d love to hear it!


Does anyone have any ideas for me on this?


Hi Jonathan,

First of all thank you for very detailed reporting, that will help us find the issue quicker!

Everything really looks correct.

Is base and rover?
Could you try to drop the config to default (button with three dots on the right of the “save”) and try to configure them again?

I’m pretty sure the issue here was due to a defective Reach board. I emailed support and was shipped out replacements, since which time I’ve been able to connect between the units.