No RC input from reciever

So I have a couple of issues. My transmitter is an FS-TH9X 2.4GHz 9CH Transmitter with the included receiver FS-R8B. My Drone is a kit from X-Heli which is an Aerosky 550 Hexacopter. Before I installed the Navio2 Board with the RPI3 I assembled it with the flight controller it came with and was joyfully flying it just this weekend so I know the transmitter and receiver work together just fine. Before I installed the Navio2, I assembled it, loaded the image and set it up. Everything appears to work fine other than the RC part. I can ssh into it wirelessly, I can connect with Mission Planner and see that it gets GPS lock, the compass and everything looks to work. I should also include that I have the telemetry kit to connect the mission planner with the Navio2. When I go to the RC calibration, nothing registers form the transmitter. Again, I was just flying this thing before installing the Navio2 so I know it works and it has PPM output. So, any help on what could be the issue would be helpful.
Another issue that may or may not be related is that I’m having an issue with the firmware upgrade. Mission planner never seems to determine that it is a Navio2 board. It asks if it’s a Beebop, PX4/Pixhawk but never asks about a Navio2. It ultimately says the board is discontinued and tries to update with some weird firmware from an unknown retired board.

I’m at work while typing this and I don’t have the image and Ardupilot version with me right now. I can update that info when I get home.
The receiver is plugged into slot 1 on the receiver and connected to the PPM connector on the Navio2. The ECS’s are connected to ports 1-6 in the correct order. When I plug the battery in, I get constant beeps that I assume is due to no RC recognized. Again. other than that, the board boots up fine.

Can anyone provide a little feedback on what’s wrong. Right now I think the board is bad and contemplating on sending it back.
Thanks for any help.

Well, no help so far so I’ll have to do this myself. I’m in IT so I’m very comfortable with this kind of troubleshooting. I’ll post what I do so maybe someone else will benefit. I think my transmitter has PPM function but doesn’t output CPPM from the receiver. I’ve ordered a CPPM encoder that should arrive today. If that resolves the RC issue, I’m sure I’ll have this Hex in the air by the weekend.
I’ll report back with the results.


Navio2 is no flightcontroller in itself. It provides the necessary sensors and connectors to the Raspberry Pi. Together with a version of the Ardupilot firmware, compiled as an executable to run on the RPi, you get a complete flightcontroller.
Missionplanner is only used to upgrade the firmware on MCU based flightcontrollers.
The Ardupilot software and OS running on the RPi are upgraded with “sudo apt-get update && dist-upgrade”. Emlid usually takes a while, before they put the newest Ardupilot versions in their repository. If you want the very latest Ardupilot software, you can compile it yourself from the sources or download from This is all very well documented in:

I received the CPPM encoder a couple of hours ago and connected it to the receiver and Navio2. It worked. I ran through the RC and ESC calibration, only needing to reverse the throttle from the transmitters settings. I got a little ahead of myself and put it all back together and took it to my now dark backyard. I got it about 3in off the ground and quickly noticed the Hex started going backwards when it should have been going forwards. Luckily I got it on the ground before losing control. Forgot to calibrate the directional sensors or there’s something else I’m not taking into account. There also seemed to be a bit of lag in the throttle response.
Enough for now. I’ll do that tomorrow after work.

schuermannsebastian, thanks for the advice.

The forwards going backwards was fixed by reversing the Elevator setting on the transmitter.While test flying I noticed that the hex wobbled a lot and was unstable. I nearly crashed a couple of times. I researched and found that lowering the Pitch and Roll rate PI’s a little bit lower. I forgot the actual number set. It flies pretty good now. It feels way more stable than with the original flight controller. I just figured out how to map the loiter flight mode to a switch on the transmitter. Can’t wait to try it tomorrow.

Went out flying this morning to test the loiter function. It didn’t work. I saw some posts regarding Mag and inclination settings so I’ll look into that. I’ve included some pix of the hex. I’ll upload a video once I get a chance.

Your frame has a powerdistribution build into the bottom plate and your RPi Navio sits right on top of it. The magnetic fields from this PCB will confuse the Navios compass.
The big lump of battery right on top of it does not help either.
And allthough you mounted the RPi/Navio on a vibration dampener, the gap to the top plate is so small, I suspect the RPi/Navio will rattle against it, totally negating the effect of the anti vibration mount.
Put the RPi/Navio on the top plate, the battery underneath the copter and some kind of protective cage over the RPi/Navio.
You will also need to put some open cell foam over the barometer to protect it from UV light and moving air. I will look at your pictures again, when I am at my PC, to see if I find something else.

Two other things I noticed:

The GPS antenna should be mounted high above the rest of the equipment, so that it has a clear view at the horizon in all directions.

The antenna on the telemetry module is quite big and close to the prop. If it loosens in flight, it will eventually strike the prop. If you had a small and a big antenna in your set, mount the smaller one on the copter.
Is this a 433MHz or 915MHz set? Sometimes the cheap china telemetry sets are packed with whatever antenna was lying around. This big antenna looks a lot like a higher gain wifi dipole. If you have range issues with the telemetry, try to get other antennas.

1 Like

Hehe. Looks like I got an F in component placement. You’re right though. I didn’t feel that good putting the boards on the lower level but I didn’t have a cover for them and I’m using cheap plastic props right now that have broken a few times when flying with the original flight controller board.I don’t want it to crash and damage my new flight controller. I have already moved the telemetry antenna and need to get a mount for the GPS receiver. This is my first Drone build. I’ve built a handful of 450 sized copters in the past but a hex is a little different and more complex with the flight controller.
Thanks for the input. I’ll ultimately heed each point you made.

I’ve moved further with the Hex and thought I’d post more pix. I’ve moved the telemetry antenna and opened a hole in the top cover so the GPS connection doesn’t vibrate against it.Before doing that, loiter and alt hold weren’t working. Now it’s working great.

Here are some pix of it outside loitering and whatnot.

The next step is to nail down FPV. I was thinking about the onboard wifi and gstreamer but I haven’t been able to get a stream going that doesn’t have less than about 5sec delay.And that’s in my house. So, I’m thinking about a 5ghz transmitter and receiver instead.
If anyone has any advice or stream script for gstreamer, please post.

I was going to post a short video but they aren’t allowed.

This topic was automatically closed after 100 days. New replies are no longer allowed.