No PWM Outputs


I have two Navio2 boards and RPis. Unfortunately, I’m having issues with them not outputting any PWM signals. They were working fine–no software has changed on the RPi. I’ve tried PX4, Ardupilot, and the Navio2 examples all to no avail. I’ve also verified the issue with a logic analyzer. My guess is that somehow the firmware on the STM coprocessor is corrupted or some other hardware issue.

Any suggestions as to what I could do to remedy this?


Could you please cat /sys/kernel/rcio/status/alive?

I get 0 unfortunately.

Are you sure that the board is screwed down alright? Try running a couple of examples. If they fail, the connection between the RPi and the Navio might be the issue. If they run without any problems, we’ll try figure out what your problem is otherwise.

The other examples work fine. I think that the PX4 latest master corrupted the IO STM chip firmware as we ran into similar issues with a Pixhawk. Would it be possible to flash the STM chip on the Navio?

Sure, it’s possible. wget && sudo dpkg -i rcio-firmware.deb should do the trick. I suggest a reboot afterwards.

I doubt that PX4 could interfere. They don’t touch the STM32 firmware. Or haven’t touched, have they?

Flashing was successful, but still we are getting /sys/kernel/rcio/status/alive is 0. Any other suggestions?

Have you tried to reboot?