No PPM/SB signal output on receiver to feed into Navio2

Hi ,

I’m trying to interface my AR6210 spektrum receiver to the Navio2.

The receiver has NO PPM/SB outputs only PWM signals on each channel for Throttle, Ale ,elv ,Rudd etc .

Can someone point me to the documentation when I can directly plug the respective outputs from each receiver channel to the Navios RC Input pins and how do I setup the firmware to read these respective channels


Navio2 only supports SBus/PPM RC input. The only way to use a PWM only receiver is to connect a ppm encoder between the receiver and the Navio2.

1 Like

Ok … I just got myself an AR7700 receiver which has a PPM output.

When I do

cd /sys/kernel/rcio/rcin
sudo cat connected

I get 1 and when I do sudo cat ch0 , ch1 I can see the channel pwm values changing.

When I run Mission planner I don’t see the green bars lit up …it is all blank .

What else can I try.

I’m running the latest raspbian image . Have done nothing fancy.
Mission planner is reporting back status from IMU / GPS etc


Could you please make sure you made sudo update-alternatives --config arducopter? The version for navio2 should be selected.

Ok I will try this tomorrow.

Since I have a rover project

I assume it will be

sudo update-alternatives --config ardurover ?

I just tried this and it all appears to be working now :slight_smile:

1 Like