No power on Wi-Fi USB dongle

I have the same issue with my wifi dongle. No power when I connect to a USB port. If connect to my Desktop it works.powers on.
I’m trying to setup EZ-WifeBroadcast. Not so sure about the Rx side of things. Do we have to solder to the Raspi inorder to have the Rx wifi working? I really am not happy about having to do that.
What should I be doing but aren’t in order to get this to work?
Please reply.


We support Wi-Fi Broadcast. Please, take a look at the docs how everything’s set up. There’s not soldering involved.

We need more details to look into the problem. Please, tell us what dongle do you use. What doesn’t work? The output of dmesg after inserting the dongle would also be of help.

I’ve had attached and working a HUAWEI E8372 LTE Wingle. The Navio had no problem providing power. The thing worked and I connected the Navio2 and a Laptop to it.

When I’ve tried to connect a TP-LINK TL-WN822N V4 nothing happens. No power, nothing. And when I try connecting one to the Rx Raspberry Pi it starts searching for wifi when it’s first turns on but can’t find one.

Why is it that the USB can’t provide power to the USB port to power a TP-LINK WN-822N USB Adapter? I’m hoping to use EZ-wifibraodcast. Can power a smaller USB adaptor but not a larger one? Must be too power hungry.

Could you please post the output of dmesg after dongle is inserted.

Using a powered hub might be a good idea as well.


If i have to go and purchase a power hub then really i may as well have just waited until The Edge came out and purchased that. I’m not a developer, just someone wanting something a bit better than the Flight Controllers being offered up to Quad Racers on ebay and banggood. I’m into Aerial Photography and Exploring using a Drone Camera. Buy the time I buy: The Navio2, GPS, Power Module, Cables, x2 Raspberry Pi 3 Model B (I purchased two Raspis), Pi Camera, x2 Wifi Modules and it still doesn’t work it’s kind of a loss cause.

DJI’s N3 Flight Controller is AUS$499. Works right out of the box. Plug your lipo on and go. Unlike this :expressionless:

Granted i think Emlids The Edge is far better (though I am now having my doubts) everything you need in terms of building a Flying Camera. But an N3 and a Lightbridge 2 all plug-n-play. The stuff works. Unlike all of this. Still all experimental.

I purchased the TP-LINK TL-WN722N today. After powering the Navio2 and then plugging in i typed dmesg. This is the message:

Sure, I can try a power hub, but is that what everyone else had to do? I’m using the same components as everyone else. I didn’t see on the Emlid Navio Page, when I read about the FC, it mentioned anything about needing a power module. I’m starting to think this doesn’t work.

I tried, out of desperation because i’m not sure why this is here:
Receiver setup¶
To start broadcast on receiver:
sudo systemctl start wbcrxd
why is this here? So I installed the Emlid Image on the Rx Raspi and typed that into the command line with the pi connected to HDMI and I entered the command for the Tx on the Navio. Nothing. Doesn’t work.

I thought what I’m suppose to do to have this work was have a Raspberry Pi 3 Model B / Navio2 with Pi Camera and a TP-LINK TL-WN722N wifi module along with another Raspberry Pi 3 Model B and wifi module and I’d get EZ-wifiBroadCast. Na! Doesn’t work. Doesn’t work, People. Don’t waste your money on this any longer.

DJI make a product called Lightbridge 2. Pair that with, say, the N3 Flight Controller and you’ll have drone you can use that actually has a working video stream. and it all works right out of the box. None of this, messing about for days and still not have it working.

All I’ve gotten for my troubles so far is a flight controller than when powers on can connect to QGC and stream video, but i’m connected to my home wifi. That’ll take me far!

Useless!! Wish I could get my money back on this product (Navio2). :face_with_symbols_over_mouth:


Please, don’t panic and calm down. I’ll try to walk you through the whole setup process. WBC is a feature for advanced users, so it might be something you need to wrap your head around.

It seems like you acquired a newer TP-Link WN722N with another chip that needs another driver. This is something that you don’t really expect from a Wi-Fi dongle’s vendor so we’ll try to make it work.

I want to ask you to keep the discussion about WBC within this thread in order to keep it civil.

So, right now you have two RPi3, one Navio 2 and two Wi-Fi dongles (WN722N and WN8222N). Am I correct?

Could you please, show us the dmesg output after you insert the latter?

Navio 2 and DJI Naza N3 are two very different products. Even though, N3 might give you a more PnP experience, Navio 2 and Raspberry Pi combo really shines when you need to tweak anything. The former doesn’t give you anything to neither tweak on nor tinker. So I totally get your frustration, but I guess you can give us a chance to help you out? I want to help, but I don’t really want you take the offensive on our product.

1 Like

Hello and thanks for the helping hand.

I get what you’re saying and I apologise for any negativity.

I’m now using two ALFA AWUS036NHA. When I connect the Rx Wifi it is working and I can see and have connected to the wifi-hotspot. Turning on the Navio2 no image to the HDMI screen. The reported frequency on the HDMI screen is 2472Mhz.

I’ve typed sudo systemctl start wbctxd to start broadcast on transmitter. Do you need to do that? If so, do I need to do that everytime I start Navio2?

The dmesg output is:

I’m not sure on the setting in QGroundControl either. But as I’ve seen that an image should appear on the HDMI screen I guess that’s the least of my worries at the moment. Still using the same setting I had when I connected before, like from the Home Network?

Does any other this seem correct?

Thanks for any help.

Going to add EZ-wifibroadcast to it’s own Raspberry Pi 3 for Tx and see if that works. See if it works by itself.

A Rx Raspberry Pi and an Tx Raspberry Pi with Camera using wifi with ez-wifibroadcaster works. What aren’t I don’t when the Navio2 is connected inorder to get this to work? I’m not using the wifi hotspot, which I was before which may have been interfering with the signal. Not sure. What do I need to do??? Obviously I’m not the first to try and do this. Others must have done this. Did you follow the Emlid instructions? If so, post the steps please. I’m not a complete idiot yet trying to follow the steps here has produced nothing.

Didn’t i read that the forums are where we can receive help? Not much support I have to say.

This topic was automatically closed after 100 days. New replies are no longer allowed.