No output on RC9_OUT and above


Whatever parameter I set on RC9_OUT and above I get no signal output.

This is what I tried:
RC10_FUNCTION to 52 (RCIN2) and pulling the elevator (or any other stick) -> servo on OUT10 doesn’t move
RC10_FUNCTION to 6 (Mount1 pan) and changing the mount angle -> no movement on servo

Doing exactly the same on any channel below 8 works fine.

No Servo_out data is sent via MavLink either, but I hear that is a separate issue?

This is the gear I use.
Turnigy 9X+PPM to SPPM converter
RPi 3
OS: emlid-raspbian-20160408
APM: Arduplane 3.5.2
Servo rail powered via ESC on channel 3.

Hi there!

First things first, I’m wondering why you’re using ArduPlane 3.5.2? The debian package has 3.5.3 and I guess it’s better to use the latter anyhow.

Closer to the issue at hand. I just connected a simple Hextronik HXT900 to all channels from 9 through 14 and everything works just fine with RC13_FUNCTION set to mount_pan. Every time I rotate my Navio, the servo moves. I suggest taking a look at the channel with a scope. I don’t see any reason for the servo not to function. Have you tried to adjust setting in the dedicated Camera tab instead of doing it manually in Parameter Tree list?

Concerning your first use-case:

Unfortunately, it won’t work at the moment because of the limitations of ArduPilot legacy code. This is documented here in the section called “The strange input/output setup in RC_Channel”. Where did you obtain this obscure 52, if I may ask? I don’t see it in the docs.

What GCS do you use? It’s possible you haven’t calibrated any channels above 8. That might be the reason for some issues as well.

Thanks for your reply!

To answer your questions:

  • I don’t know why I have arduplane 3.5.2 I thought I had used the debian package from the emlid site. Anyway: in the release notes there are no bug fixes with regards to the higher channels. So I’m not sure upgrading will change much.
  • I don’t have a scope, that’s why I used a simple servo. Should I try to find a friend with one?
  • I use APM planner 2.0.20 for Mac. I used the dedicated Camera tab, but it’s a little buggy. Setting the paramaters in the full list usually works better.
  • Does calibrating do anything more than setting RCx_MIN, RCx_MAX and RCx_DZ? I set those manually to look similar to the other channels.
  • The obscure 52 parameter is found in the docs here.

Could the problem be with the PPM signal, that it contains only 9 channels? I have no Idea what to change and test now. What mystifies me is that exactly the same parameters and setup works on channels below 9, but not on channels above. The only thing I haven’t checked is whether there’s 5v on the upper channels + pins. Will do that later.

AFAIK, it’s not possible to control a servo with a nonmatching RCIn channel. That’s why you need a RC receiver and transmitter that support more than 8 channels in order to control channels above 8.

These are the parameters i changed.


After these adjustments and a reboot, the servo I connected to 10th channel started moving in response to roll changes.

I suggest trying out QGC!

I downloaded QGroundStation, thanks for the tip!

I did more experiments today but had more trouble.

$ sudo ArduPlane -A udp:
Raspberry Pi 2 with BCM2709!
No INS backends available

Now ArduPlane refuses to boot. I have a spare Navio2 and will try with that one during the weekend.

Solved it. More or less. Some contact spray and tightening of the screws on the connector between the PI solved the INS backends thing.

Next I did:

$ sudo apt-get update && sudo apt-get install apm-navio2
$ sudo apt-get dist-upgrade
$ sudo reboot

This upgraded to ArduPlane to 3.6.0
Now setting a default angle using MNT_NEUTRAL_Y moves the servo on channel 10, when it is assigned to MNT_ROLL. But stabilising still doesn’t work. I’ll have to dig some more into this.