No interface or network connectivity


  1. Currently using the latest Stretch Raspbian version of the OS
  2. Been following through the instructions for installing the OS Image. It flashes to the SD card ok but when I put the SD card into the Raspberry Pi and connect it all I get is a rainbow coloured screen and no CLI and cant SSH on to the Raspberry Pi either. I have used these things a lot before but never had this problem. Any suggestions as to why the OS is not being flashed properly with Etcher?
    I have the NAVIO 2 board and a Raspberry Pi 2 B (i think, been a while).
    Trying this out as part of a school project between our school and two others across Europe. Goal is to build a flight controller for a drone using the Raspberry Pi.

Any and all help appreciated,

Have you tried other OS on your SD card? and does it work?

Just tested it with a freshly downloaded version of Raspbian Stretch on the same SD card, which is new and straight out of the box, and it worked no problem.

Could it be the image from the NAVIO site is not downloading correctly and maybe has an error in it when I download it?

Have run a Emlid version of stretch or jessie before?
How do you connect to Raspberry? wifi, cable ?

Currently wireless but the CLI doesnt even seem to load properly via the HDMI and SSH doesnt work.

Have tried wired and wireless.
First time with EMLID but cant see how its too different to other projects I have done

Strange. Should get the command line up . Do you have a picture of what happens when you boot rpi with stretch?
Whats your powersource ?

Clean install of the EMLID OS from their site.
Being powered by a 11.1V lipo as that will power the drone this will be a part of eventually. Does the same thing when Pi powered directly

The same happens if you power rpi with the usb cable? 2.amp source? and without the usb dongle attached
Edit: also verified the m5d checksum?

Currently using a samsung charger which can do up to 2A output and still just the rainbow screen. Was not sure how to run the checksum to check the download but have downloaded the image a couple of times and always the same result. Surely it would be getting 2A from the lipo battery? It runs regular stretch from the battery just not the EMLID version

I just tried with mine and i get for a second or two just the same rainbow thingy before OS is lunched.
Both with lipo or 2amp usb bank.
Would look at the image and make sure its properly flashed. I assume you run latest version of etcher?

This is what you should get after the rainbow

Yes that is what i was expecting to load. How do i use the checksum ?
Also is it worth decompressing the .img file out of the .xz archive ?

Yes latest version as I have used a different image program in the past.

Might try a new sd card but dont see how thats a problem since I tested it.

How to test m5d

Just downloaded and flashed Emlid Stretch with latest etcher and everything worked just fine here.

Took the image out of the xz file and checked the MD5 and it matches but when I put the img file on the SD card nothing different happens.
Is there any other way to check if the Navio I have could be causing it. Normal Stretch runs but it ignores the Navio hardware. Could that be the issue ?

Just put it in the Pi wothout Navio connected and the OS began loading. Faulty unit ?

Could be, but lets hear from @emlid


Have you tried with another Raspberry PI?


I bought another one and it worked. Must have been a fault in the Raspberry Pi I had