Emlid

Community Forum

No Heartbeat Radio


(Guido Steijaert) #1

I complete new and learning fast at the moment. The telemetry radio does not have a heartbeat.

With Missionplanner 1.3.65 And ArduRover 3.4.2 In the Sik Radio Part I get the Local information, but no remote information.

I there a possebility to do a kind of diagnostics on the raspberry to check if the radio connected to the Navio2 board is working well?


(Tatiana Andreeva) #3

Hi @guido,

Please share with us:

  • hardware setup photos;
  • the content of /etc/default/ardurover file.

Thanks!


(Guido Steijaert) #4

Sorry,

Some photo’s with the asked information.


(Tatiana Andreeva) #5

@guido,

Have you connected 5V and GND radio pins to corresponded Navio2 UART pins?


(Guido Steijaert) #6

yes I did, the green led is blinking. It should be continious on to have a fix.

Is it an option to buy an usb-rs232 converter and try to connect thru USB?


(Tatiana Andreeva) #7

@guido,

Blinking green means the radio module is searching for another radio.

Are you sure you set up similar settings on both radio modules?


(Guido Steijaert) #8

@tatiana.andreeva

The Air part does not have a USB connection. I m going to get a USB-RS232 converter. Then I’m able to connect it to a PC to check the settings.


(Tatiana Andreeva) #9

@guido,

Are you sure your radio has RS-232 output, not UART?
Could you please share the datasheet of this radio module?


(Guido Steijaert) #10

It is uart


(Tatiana Andreeva) #11

@guido,

So, you’ll need USB to UART converter, not USB to RS-232. Am I missing something?


(Guido Steijaert) #12

You are right. I did order the wrong one.


(Guido Steijaert) #14

I did get the UART coverter. Connect everything and still no link between the radio’s.

What I did:

  • connected the groundradio to my notebook and did an update of the firmware
  • connected the airradio to my notebook and did an update of the firmware
  • connected the groundradio to my notebook
  • connected the airradio to the raspberry (USB)
  • did change the settings from UART to USB on the raspberry

Now the radio’s pair, green led’s are solid.

But when I try to connect with missionplanner, no connection with the rover. When I connect the rover with a cable, over UDP evrything isworking well.

I think I’m close, but I miss something.


(Tatiana Andreeva) #16

Hi @guido,

May I ask you to share the /etc/default/ardurover file content again?


(Guido Steijaert) #17

Hi @tatiana.andreeva,

Thank you for your effort. after a restart it is running well.