"No HeartBeat Packets received" when trying to connect to mission planner

I’m using arducopter 3-5 and emlidtool version 1.0.0
I am trying to connect my Hexacopter to my mission planner via 3DR radio and cannot seem to connect to my PC. I already established a connection between the two radios and when I go to the optional hardware section of mission planner using the “Sik Radio” tab I am able to receive the settings from both when I press load settings. My problem is when I press the connect button on the top right of the mission planner screen. Every time I press it my connection to mavlink times out and responds to me saying “No Heartbeat Package Received”.

Whenever I press connect on my mission planner this is what appears on my raspberry pi screen.

I feel like at this point ive tried everything to make these telemetry radios work since the wifi at my school is very unreliable. I tried following the steps in the docs but I guess I’m not very good at this and cant get these radios to work. Any tips will be greatly appreciated since this is my senior design and would really like to graduate this year :joy:

this is the picture of how I have my connections set up at the moment.

Try changing the UART to /dev/ttyS0 in /etc/default/arducopter. You can also try to disable bluetooth and use /dev/ttyAMA0, following this guide:

Hello Sebastian thanks for the help,

I tried both steps you provided and still its still a no go. every time I try to run
sudo arducopter -C /dev/ttyS0


sudo arducopter -C /dev/ttyAMA0

depending on the settings that I put them to I get this

These random messages will continue until I force quit and now my antennas wont even connect. Besides what is on the docs for the navio 2 is there anything I must do software wise on the raspberry to get the flight controller to work ? at this point I cant even get it to communicate with my mission planner.

thanks for your time.

Those messages are the telemetry send to stdout, because you left out the -A option. No matter what the ardupilot settings are, the radios should connect a few seconds after they get power. Check if the settings of one of the radios got corrupted.

How would I check the settings of the radio to see if they got corrupted?

In Missionplanner, initial setup, optional hardware, sik radios. There you can configure your sik radios. Since your radios do not connect over the air, you will have to connect them both to USB.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.