No heartbeat packets received, can't connect to Mission Planner

Hello everyone, I am trying to connect my NAVIO2 to Mission Planner 1.3.50 in Windows 10, and when I try to click connect, I get a message that reads “No heartbeat packets received”. I selected the correct com port and made sure that the baud rate is 57600 on Mission Planner and the com port in the device manager.
Please somebody help me, I would much appreciate it.

Can you please post settings of your launching options /etc/default/ardu[your vehicle]?

This topic was automatically closed after 100 days. New replies are no longer allowed.