No Grey Bars

I’ve just got my two Reach RS + units set up by following the Emlid tutorials.
I’ve followed the tutorials to the letter in the video but i never get the grey bars to accompany the reddish/orange/green ones.
I’ve placed both units on the window cill as described and get around 22 stats but the signal to noise ratio stats graph always shows Base as Zero which i’m guessing is where the problem is?
Both base and rover and showing in the Emlid app and all settings match.
No matter which unit i’m logged into the base is always zero and rover around 22.
Can anybody shed any light on why this is please?
They are both connected to eachother via the hotspot.
Many thanks for any help you can give.

Hi Michael, you may not have assigned to each unit which is the base or which is the rover. To see the grey bars (which is required when doing rtk work), you have to:

  1. Determine which unit you want to use as base and which to use as rover
  2. Go to the ‘base mode’ tab within your designated base unit, choose Lora tab and choose any of the options based on how to obtain base coordinates for you project (that is, the designated base must have a coordinate, whether you obtain it from averaging fix or float from an ntrip source, letting the unit average the coordinate in single mode or manually entering the coordinates) . Make sure your frequency and air rate match on both base and rover also remember to check the RTCM3 messages of your preferred constellation.
  3. Go into your Rover unit and go to the correction input tab, turn it on and choose Lora and make sure the settings match that of the base units.

Note: make sure you turn on the base unit first and set it up before turning on the Rover unit to configure it as well.
Hope this helps you. Stay safe!

1 Like

Thanks very much for your prompt response.
Even after switching on the base unit and setting it all up, in the status window above the sats bars where it has two blue tabs that say Rover and Base, it still only shows the amount of sats on the Rover?
There is only one unit switched on as i’m looking at it now and i’ve set it up as a Base but it still shows Rover sats… Hope that makes sense.

Do you see satellites in the status screen of the base?
Could you share the simple report file for both units?

I appreciate your help with this!
My main issue at the moment is with setting one unit up as the base. I’ve gone through the set up procedure and gone through the base mode settings etc but it still only shows as a Rover receiving sats… i don’t have the other unit which i’ve set as a Rover switched on this morning yet as i’m trying to get this Base sorted.

All i’m trying to do at present is set them up communicating to eachother in my garden so i’m not using NTRIP or anything at the moment.

Here’s the report from the currently switched on unit that i’ve designated as a Base: -

Simple system report
app version: 2.22.5-r0
'wifi_status, interface: wlan0':
- wifi_mode: ap
- access_point:
band: bg
channel: 1
password: null
is_added: true
is_connected: true
mac_address: 6C:21:A2:3A:0C:F8
security: wpa-psk
ssid: PS-Base:17:B3
uuid: 8220fdfc-65e0-4206-b7e1-c6749e5cb681
base mode:
base coordinates:
accumulation: 0.10000000000000001
antenna offset:
east: '0'
north: '0'
up: '0'
- 0
- 0
- 0
format: llh
mode: single-and-hold
enabled: true
format: rtcm3
path: lora
type: lora
rtcm3 messages:
enabled: true
frequency: 1
enabled: true
frequency: 0.10000000000000001
enabled: true
frequency: 0.5
enabled: true
frequency: 0.5
enabled: false
frequency: 1
enabled: false
frequency: 1
enabled: false
frequency: 1
discoverable: true
enabled: true
pin: '***'
- - 863000
- 870000
correction input:
enabled: false
format: rtcm3
path: lora
send position to base: 'off'
type: lora
enabled: false
format: RTCM3
io_type: tcpsvr
path: :9028
device: null
format: RTCM3
started: true
format: RTCM3
started: true
debug: false
interval: 24
overwrite: true
format: UBX
started: true
format: LLH
started: true
air rate: 9.1099999999999994
frequency: 868000
mode: write
output power: 20
position output:
enabled: true
format: nmea
path: bluetooth
type: bluetooth
enabled: true
format: llh
path: :9001
type: tcpsvr
rtk settings:
elevation mask angle: 15
glonass ar mode: 'on'
gps ar mode: fix-and-hold
max horizontal acceleration: 1
max vertical acceleration: 1
positioning mode: kinematic
positioning systems:
compass: false
galileo: true
glonass: true
gps: true
qzss: false
sbas: false
snr mask: 35
update rate: 1

Just to be sure. Even though you edit settings on the base, you will not see grey bars in the status screen of the base unit. You have to be logged on to the rover and rover unit only to see those grey bars.

Here is a screenshot of my base sending correction to my rover. In a working condition. No grey bars and the colored ones shows as rover. But still, its a base unit.

Aha ok.
So even in Base mode it only shows the Rover sats?
I’m having a bigger issue this morning as i’ve just tried switching the Rover on and not allowing me to connect to it… there’s no wifi signal being generated by it.
Might be something to do with updating the firmware yesterday.


What does the blue LED do? Flashing or steady blue

Yes like the image you sent through… even in Base mode with just the base unit on it shows the sats under the Rover tab.

I am referring to your connection issue and the orange/blue/green led in front of your unit.

It’s all changed this morning ha ha.
I have never used these units properly for surveying due to a change in circumstances when i bought them but yesterday i wanted to get them up and running again so went through the set up procedures and necessary unit updates and they connected to my ipad fine and both showed up in the Reach app…
This morning when i tried setting them up outside i can’t connect to both at the same time… the blue light has been flashing on one so i took it out of range of the house wifi and restarted and it came solid blue but then i tried the same with the other unit and now that won’t connect.
I’m finding the Emlid docs a bit contradicting with regards to set up and they don’t match with their online videos.
I only want them set up as a basic surveying kit to start and then i can start altering settings for corrections on NTRIP etc.

Sorry for the long reply ha ha… just getting a bit frustrated as it’s proving more difficult than using a Trimble kit i used almost 20 years ago! ha ha.

Hi Michael,

May I ask at what step do you find the docs contradicting? Could you please share the video you are referring to?

Are you using LoRa for RTK? Have you attached the LoRa antennas to the units? Could you post System reports from both base and rover?

No problem. I find child safety lock sometime difficult to operate and tends to jam up when you least want it. But that doesnt mean its not working, you just need to know how to operate them :sweat_smile:

I think the hotspot mode and which device has the mode operating is confusing some.
In your case you should look at the blue LED light in front of the unit. If its steady blue, the unit is in hotspot mode and you must use your phone to connect to its network.
Blue LED blinking means it is connected to a nearby wifi and your phone must be on the same network to see the RS unit.

For setting up units and play with different setting i would recommend having all units connected to a local wifi with internet.
And what Dmitriy said :point_up_2:

1 Like

Thinking that too many changes had been made i decided to start again from scratch and re-flash both units via the emlid flashing tool… the flashing failed on both units!
I used the supplied usb, it recognises the reach unit asks to select the image and at this point tells me the downloaded image is out of date and i need to use the recommended one that pre-fills in the grey box.
I selected that it says initializing but then comes up with the failed message and then starts looking for the device again.
It keeps failing and now i can’t find any of the devices in my wifi list when i switch them on.


When you power on the devices, please let them boot (Green LED should get solid).

Then, if blue LED is blinking, make sure your mobile device is on the same network as Reach and check it via ReachView app.

If blue LED is solid, you should see Reach in the list of available Wi-Fi networks.

Once you get into ReachView, you can go to settings and reset the unit via software. Or you can download system reports and post them here so we help you tune the settings.


I’ve been waiting around 20 minutes for the green light to stop flashing now.
pwr and net are both solid.
The unit is showing in my ipad wifi list but will not connect through the Reach app.

Hi Michael,

I’ve just sent you a PM, let’s try to troubleshoot it further.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.