No fix with corrections over RFD900

Just now I use 16 air data speed, then tx power 20, result is I can’t get fix quick, about half hours, then the range is only about 100m. Now I’m changing rate to 32, then tx power 10.

Good plan. When my air data rate was too slow, I saw the grey bars of the base disappearing and coming back, and sometimes disappearing totally after a while.

Your TX power should not have to be very high if you have a clear path between antennas. If you have version 2.x firmware, then the TX power adjusts itself automatically, and the setting you make is for the maximum TX power. With the older 1.x firmware the TX power level is fixed to the setting you make.

My tx power is fix in my setup, firmware is 2.6. still get about 100 in tx power 10 then 32 air data rate. Do you have suggestion for rfd900 antenna position?

[quote=“rfdesigns”]Dynamic transmit power control.
…the modem is able to change its transmit power level automatically to reduce current consumption while maintaining a good RF link…[/quote]

But you know, I can’t see the R0 and R1 registers for setting this dynamic option, so maybe you are right that the TXPOWER is fixed. I will have to look into this a little deeper.

How’s the fix time with the new settings?

I still more time to get fix. More than 10 minutes. I break for an hour with my team. Will continue later with yesterday configuration, 10 tx power, 64 air data speed, and gps_glonass_5Hz.
The tentative conclusions are tx power 20 air data speed 16, 20 power 32 air speed, 10 power 32 speed (need more time for fix, short range). Now change to 10 power 64 air data speed, yesterday I get 200-300 m range and 1,2 or more for fix. But I don’t know what the result next. I hope same or maybe better then yesterday.

Well hopefully it gets quicker for you.

What worked well for me was:

               ,--------------.
               |    GNSS      |
               |   antenna    |
--------g--r--o--u--n--d----p--l--a--n--e--------
           |                      |
           |       RFD900         |===========: stubby antenna parallel to ground plane
           |       radio          |
           |                      |==\
            \____________________/   ||
                                     ||
                                     ||
                                     ||
                                     ||
                                     ||
                                     ||
                                     ||
                                     -- 
flexible antenna (perpendicular and underneath the ground plane)

I will try later, and upload the picture.

More familiar for me. I have no experience typing code.

Far from fix. After update to 0.49, I get fix just a second, then float. I change to fix and hold the result same.
Hi bide, may I know all your configuration of reach and rfd900? May be I will start with your configuration.

I haven’t used 0.4.9 for RTK yet, just for development. I will give RTK a try and let you know. It might take a day though.

@dicky Did you know that you can test all the older versions of Reach by using git?
(This is from memory, so it should work)

  • ssh into Reach
  • stop ReachView by killing the server.py script
  • ps | grep server.py (show the process IDs of ReachView)
  • sudo kill 1234 2345 <-- change to the process ID numbers from last command
  • cd /home/reach/ReachView
  • git tag (lists all the versions)
  • git checkout v0.4.7 (to switch to different ReachView version)
  • sudo /home/reach/ReachView/update.sh this will update or revert the binaries in the /home/reach/RTKLIB folder
  • *edit: running the update script will obviously re-update ReachView as well, so don’t run it if you are online. Either that or read the update script and learn how to update the RTKLIB binaries manually
  • start ReachView by rebooting or sudo python /home/reach/ReachView/server.py&
  • then you can exit from ssh

When you want to go back to the latest ReachView version, then just:

  • git checkout master to go to most recent version
  • sudo /home/reach/ReachView/update.sh to put the latest RTKLIB binaries back in the RTKLIB folder

Is that mean with sudo to?
Sudo /home/reach/ReachView/server.py&

That’s great. Thank you bide for your concern. I will do it tomorrow, because this morning until night maybe i will use total station for mapping the road, it has been run out from time schedule.

yes, I’ll correct my instruction above

I can not wait to type the code, so I do now…

sorry, “change to the process ID numbers from last command” is that mean I should choose such as like before, choose first coloum first line?
454 root 33020 S {server.py} /usr/bin/python /home/reach/ReachView/se
515 root 22412 S {server.py} /usr/bin/python /home/reach/ReachView/se
733 reach 2660 S grep server.py
sudo kill 454?

yes, then run ps | grep server.py again to make sure it was killed

Done, should I ctrl-z ?

if you used the & at the end then you should be able to type exit and enter.
if you didn’t, then, yes, CNTRL-Z then make sure you also run bg to background the process

I couldn’t see floating graphic. My ReachView is 0.4.7 now, that’s great…

1 Like

I have done with my base, but my rover is still 0.4.9, even though I have done with same code…