No data when echoing the topics

Hey, I’m using the latest image and I went step by step through ROS tutorial, It all seems good, And I could connect to APMplanner 2.0 and also see the topics list but I can’t echo the topics for example when I do rostopic echo /mavros/imu/data I get nothing. Please Any suggestion Because I’ve been trying for long and I’m desperate Now, Thank you

I tried this command as suggested in other forums rosrun mavros mavsys rate --all 10 but it didn’t work for me. and I want to point out that when running

pi@navio: ~ $ rosrun mavros mavros_node \
_fcu_url:=udp://:14550@ \

I don’t get the same output like in the tutorial video. there are no writings in red or yellow color. what could be wrong!! PLZ HELP

guys, I have just two weeks to submit my project so PLZ can anyone tell me what might be wrong!!
I saw in the other forums and most of them it was because of stream rate but it was set in my case.
and I have another basic question, should we create a catkin workspace. Sorry I am new to this thing

Sorry, it’s taken me so long to reply.

Could you please post these:

  1. the output of emlidtool without ArduPilot launched
  2. cat /etc/default/arducopter or what exactly binary do you use?
  3. sudo journalctl -u arducopter (modify to the actual vehicle you’re using) after a sudo systemctl start arducopter

Yep, in case you want to develop a ROS app, that’s a way to go.

Hey, Glad you replied. Now it is OK. it was just small typo in the IP address and wait for some time for it to start to publish (Sorry for disturbing). I asked if we should create a catkin because I saw when installing MAVROS you should have a Catkin workspace but now it is preinstalled so I thought that it already created . Now I can see IMU data when publishing /mavros/imu/data but I have some issues with other topics. For instance /mavros/global_position/local it gives a wrong data and topics of /mavros/local_position/..... (pose, odom or velocity) they hang till I kill the process with ctrl+C. So should I have a GPS to get the position?. What I want to do is trajectory planning, please tell me from which topic I can get the position and where I can send velocity?
Thank you

Usually, it’s a yes because other solutions will be more difficult to integrate (it can be some combination of lidars and visual processing. But I don’t think it applies to your specific case).

OK, I have another question, the installation of ROS was it Desktop-Full because when I run rqt_graph I get nothing.

rqt_graph is a GUI tool that should be run a PC rather than Raspberry Pi that should be used for data storage/manipulation. So it’s expected that rqt_graph yields nothing. I hope I made it clearer!

Ok, Thanks

Please, tell me why I’m getting nothing from the topic /mavros /altittude it should get the data from the barometer and it is working just fine besides I’m getting the altitude on my CGS.
And also I want to ask you about the Raspberry Pi camera module and Mavros extra package. when connecting the camera to its port on the RPi we get the vision position directly published on vision_pose/pose topic or it needs some configurations.
I tried to take off and land with rosservice, after setting mode I armed but it gives me an output saying:

success: False
result: 4

What might the problem be! Thanks in advance


Unfortunately, you can’t echo messages from topic /mavros/altitude as it never gets them at all. It happens due to the fact that ardupilot doesn’t send MSG_ALTITUDE messages to mavros. Take a look at this PR. The necessary functionality was implemented but was not added to release.

I’m looking into this problem now and will try to clear it up.

This topic was automatically closed after 100 days. New replies are no longer allowed.