No data when echoing Mavros

Hello everybody,
I’m trying to use autopilot with navio2+raspi. I followed the Docs but no data when echoing Mavros. I saw this topic https://github.com/mavlink/mavros/issues/750 , they say that it’s just a question of time. I run macros and waited about 1 hour and still no data. someone can help?

Hello, Liam!
Could you please show me your output and contents of ardupilot.conf?

I too had a problem with this. Make sure you are editing etc/default/arducopter and not etc/default/ardupilot. The data entered into /ardupilot does not have any effect on anything. I am assuming you are using arducopter for a multi-rotor copter? If you have your computer’s IP address in etc/default/arducopter already, you need to delete it and replace it with the exact line they have in the docs. When you run the mavros command, this is where you specify the IP address if your gcs. The IP address of your GCS does NOT have to be in the etc/default/arducopter file anywhere. The mavros node needs to be running on the pi and communicating with ardupilot in order for the mavros node to then connect to the gcs. When it mavros starts correctly (you will see yellow warn lines) you can then open missionplanner or whatever gcs software you are running and the imu/data topic will publish data when echoed. If the gcs ip in the mavros command and etc/default/arducopter file are not setup exactly like they are in the docs, the mavros node will not run correctly. Don’t waste time on trying to change the rate at which data is flowing. The data won’t flow if these steps aren’t followed. (I wasted weeks on this issue) Also, the imu data should publish almost immediately, you’ll know if you are or aren’t going to get data after a few second, especially if the yellow warn lines didn’t appear when you run the mavros node.

Its works ! 38jonesp you had right, thanks for your reply.

1 Like