No connection to Reach RS2 hotspot

Hi, I have problems connecting to my Reach RS2 when it is in wifi hotspot mode. I am using ReachView 3 on an android Moto G7 Plus. The firmware is in the newest version (28). The problem looks like this:
I connect to the reach:94:06 wifi network. When mobile data on my phone is ON, then no connection to the RS2 is possible in ReachView. If I turn mobile data OFF on my phone, then I can connect to the RS2, but now I have no internet connection, and so cannot use NTRIP (Sapos).
I was searching for this problem here in the community but did not find anyone with the same issues.

Hi @simon.baier

You probably do not have a sim card inserted in the RS2 right?
In this case you need to connect the RS2 AND your mobile device to the same network which has also internet access. This can be the WLAN network in your office or enable the WLAN hotspot of your mobile device if your are out in the fields.
To do that connect your mobile device to the hotspot of the RS2. Then go to WLAN settings of the RS2 and choose the WLAN of your choice having internet access. The RS2 will then disable the hotspot and connect to the WLAN you have choosen. Then you need to connect your mobile device also to the very same WLAN. After that refresh the receivers screen in ReachView3.
Important to know: On boot the RS2 will look for a WLAN network it already knows. If there is one in reach/nearby it will connect to it. If not it will enable the hotspot.
https://docs.emlid.com/reachrs2/quickstart/connecting-to-the-internet
Best regards Roland

Hi Roland, thanks a lot for your answer. This is exactly, what we are doing right now, to work around this problem: We have a second phone set up as a Wifi hotspot.
However, some months ago, we used an older firmware. It was no problem to just connect the first phone to the RS2 hotspot and just use mobile data (LTE) as an internet connection.

Hi Simon,

If Mobile data is enabled, it can prevent your smartphone from connecting to the Reach hotspot. So, it’s indeed better to turn it off before you connect.

Reach can’t get base corrections via NTRIP if it works in the hotspot mode and there’s no SIM card installed. Alternatively to Roland’s suggestion with an external Wi-Fi network, you can connect Reach to your mobile hotspot. It requires only one mobile device, so I feel it can suit you better.

Here’s the guide: Connecting Reach to the Internet via Mobile Hotspot. If any questions come up, just give me a shout :slightly_smiling_face:

Simon, I have a Moto G7 and also need to disable phone data before connecting to Reach hotspot. This seems caused by the phone model. It isn’t a problem insofar as you can reactivate data after connecting but, as said above, you need to put your phone in hotspot mode for Reach to get access to the internet anyway.

No second phone is needed, just deactivate data for the brief moment you want to connect to RS2 in the app. I use my phone for NTRIP/TCP corrections all the time.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.