No BT connection between RRS and tablet (reachview)

Hey there,

I have connected my tablet with the RRS via BT but the RRS will send no data.

Here the Report.

Simple system report
app version: 2.10.0-r0
'wifi_status, interface: wlan0':
- Client state
- IP address: 192.168.1.87
  mac address: fc:db:b3:9d:8a:78
  ssid: Fritzbox
base mode:
  base coordinates:
    accumulation: '0.1'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
  output:
    enabled: false
    format: rtcm3
    path: ntrips://:r-K4848kd@fps-rtk.bayern.de:2101/FPS_BY_RTCM3_2G#rtcm3
    type: ntrips
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1008':
      enabled: false
      frequency: '1'
    '1010':
      enabled: true
      frequency: '1'
    '1019':
      enabled: false
      frequency: '1'
    '1020':
      enabled: false
      frequency: '1'
    '1097':
      enabled: false
      frequency: '1'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: true
  enabled: true
  pin: '***'
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: LFPS_marwie01:***@fps-rtk.bayern.de:2101/FPS_BY_RTCM3_2G
    send position to base: single
    type: ntripcli
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: false
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: false
    version: null
  solution:
    format: LLH
    started: true
    version: null
lora:
  air rate: '18.23'
  frequency: 868000
  output power: '20'
position output:
  output1:
    enabled: true
    format: nmea
    path: bluetooth
    type: bluetooth
  output2:
    enabled: true
    format: llh
    path: :2013
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'on'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: false
    glonass: true
    gps: true
    qzs: true
    qzss: true
    sbas: true
  snr mask: '35'
  update rate: '1'

so actually thats the reasen i wonted to Flash the RRS because i thought that might help.


Here is the correction Input


Here the Position Output


Thats the BT Connection on the tablet to the RRS


And the BT Setup at the reachview. It says connected but there are no signals coming.
Any ideas?

It sounds a Little like that one No float nor fixed mode and no grey base bars for specific Reach RS modules

Hey Martin,

How did you check that no data is received on the tablet? Until there is an app that actively listens you might see send errors in ReachView.

Hi ivereninov
In zur 2nd Picture is a Sending Error. Ans in reachview (status) i have no Grey bar from the correction Input.

You are seeing “send error” because there is no active app on Android that is reading the position.

What does it mean? I thought reachview is for that.
Do i need an other app?

ReachView works through Wi-Fi, not BT.

What configuration are you trying to achieve?

Well i want to have the exact Position on a map (Fieldnavigator) so i can correct my driving

I’ll just jump in here because it’s night time in Russia and Igor is sleeping and you’re not.:wink:
Reachview is the app you’ll use to control your settings on your Reach RS. You will access this by connecting to Reach RS via wi-fi. That’s where you’ll “pair” your Reach RS with your device that is running Fieldnavigator.
Probably you need to set position output to NMEA via bluetooth. You will do this on Reachview app.
Then your position information will be sent to Field navigator via bluetooth. Settings are accessed in the Reachview app, but the position is sent by bluetooth.
You cannot access the app via bluetooth. You have to be connected by wifi.
Hope this is clear.

3 Likes

Well i was also Sleeping :grinning:
I got the idea of reachview. I also got that the reachview needs WiFi die Setup.
My Problem is, that i have only the orange and green bars for the sattelites in reach View.
As far as i know there schould also be grey ones from the correction Signal.
But there are none.
The correction Input is working (picture 1st post)
The BT for Output is not Working (picture 1st post)
So somewhere i have to fix the BT Problem.

Does Reach RS have a single position? Many NTRIP casters require that a receiver sends its position before they provide corrections.

Have you tried connecting to the Reach bluetooth in FieldNavigator?

Hi ivereninov
What means Single Position? Is it where i have there options?

I connected it to fieldnavigator and there is a GPS Signal (GPS in Tablet off) nur it is not right. The Signal Jumps around (3 to 5 Good Satellit Signals = green bars)

Yes its Working.
Solution: flash RRS Disconnect BT and connect Everything again.
Why its Working Now i dont know. Didnt chance anything.


Thx die all your help

1 Like

Now i understand.
At the rtk settings i have to use single at the Positioning mode until i reseav correction signal and then Switch to the kinematic

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.