No Beidou and SBAS satellites

I’m located in the south east corner of Australia where Beidou and SBAS satellites should be visible.

According to GNSS Radar I should have more Beidou satellites (10) visible than Glonass satellites (8).

Below are my settings for using Beidou satellites.


Below is the ReachView GNSS predictor when configured to use Beidou.

In practice I do not see any Beidou (C) or SBAS (S) satellites.

Below are my settings for using GLONASS satellites.


Below is the ReachView GNSS predictor when configured to use Glonass.

In practice I do not see any SBAS (S) satellites.

Here is a summary of the satellites I can see when configured for Glonass (top) Beidou (bottom). Note, there are no Beidou and SBAS satellites visible when they are expected to be.

Why do I not see any Beidou or SBAS satellites?

I’m using the latest version of ReachView (2.7.4).

Regards, Ben

@graham @HELImetrex @Simon_Allen @Vertiguy @mojito33

I can see you guys are all located in Australia (like me).

Are any of you all able to see Beidou (C) and SBAS (S) satellites with ReachRS?

Regards, Ben

You can only see Beidou if you turn off GLONASS.

SBAS adds a couple of sats, and can be on with either GLONASS or Beifdou

1 Like

Hi @Simon_Allen ,

Thanks for your reply.

I understand that I can only use one or the other when it comes to Beidou and GLONASS. When I disable GLONASS and enable Beidou I still do not see Beidou satellites.

Base RTK settings

Base RTCM3 messages

Rover RTK settings


I can only see GPS, QZSS and Galileo.

I’m struggling to maintain a reliable fix with GLONASS. Since you are able to see both GLONASS and Beidou which do you choose to use? Which is more reliable?

Regards, Ben

Is this between two reach units or between a reach and another (say ARGN) reference station?
I use GLONASS primarily because all the Auscope and ARGN reference stations are GLONASS enables, but only some are Beidou enabled.

No idea why you are not seeing Beidou, but I am getting good results with GLONASS + all the others.

If it is between reach units. I know it sounds obvious, but ensure the base really does have that clear sky view. and has a good 20 mins to settle.

Yes, this is between two reach units. Here is a photo of my set up.

I would really like to experiment with Beidou because there are consistently more Beidou satellites in my area than Glonass.

See those trees…
Seriously, They are a problem for the base!

I had/have the same issues. I spent ages waiting to get a fix with my base in a similar location to you. If I used the ARGN reference I got FIX in minutes, even seconds. Moved my base way out into the open and bang far, far better results.

With your base in a really, really clear area the rover can cope with a few trees, with both around trees, welcome to FLOAT.
Windy days make it even more critical.
Hope this helps.

Thanks Simon.

I will move the base right out into the open to see if that improves things.

Thanks for your help. It’s very much appreciated.

If you record raw and proces it, you will easily see if your spot where reach is placed can see satellite systems.
(that crosshair icon at the end of file path in RTKpost)

1 Like


Thanks for pointing me in this direction.

I have ReachRS configured to work with the following satellite systems:

  • GPS
  • Gallileo
  • SBAS
  • QZSS
  • Beidou

Here are the results for GPS, Galilieo and QZSS

Here are the results for SBAS and Beidou

It appears that there are no Beiduo or SBAS satellites visible but according to GNSS radar there is.

Why would the ReachRS not be able to see there satellites?

Is this log in. Ubx og rinex format?


I am pretty sure rinex will only record what’s within the setting set in RTK setting menu of Reach.
If. Raw. Ubx is used, everything is saved.
You might wanna check that

Can you please check one thing in the field? It seems our settings do not handle a certain scenario properly. When you are disabling GLONASS and enabling Beidou in one setting apply, it will not work. Can you disable both, then enable BeiDou and see if it will show new satellites inside ReachView?

Indeed, if I disable both GLONASS and Beidou and apply, then enable Beidou and apply, Beidou satellites are visible. However, after a restart Beidou satellites are no longer visible and the procedure must be repeated again.

This workaround does not work for SBAS satellites.

This is inline with what I have found. Issue confirmed.

Well, the chart doesn’t really display all satellites, just the ones with best SNR, so they are probably still there.

After looking again at your screenshots, I can see you’ve got SBAS on: 129 and 137 are SBAS sats.

Is there a reason why SBAS satellites are not prefixed with an “S”? This is what I would expect from the documentation here.

Because they are not satellites but ground control station? (Satellite-based augmentation systems)
That is just a wild guess from me

Space Based Augmentation System SBAS signals come from geostationary satellites, they broadcast corrections which are optimised for a specific region, the European EGNOS or US WAAS, but while transmitting their corrections they serve as additional satellites in the constellation, which is how they are used in RTK. If I remember correctly they have their ID numbers of over 100 to identify them in any GNSS. So as they already have a unique ID (of over 100) sticking an S in front of that number is superfluous.