No Auxiliary Input on Navio2

Hi, just swapped from a pixhawk to Navio2 on RPI3. Everything setup the same and seems to be working good however on mission planner i have no detected PWM on channels 9-14 and nothing on the RC out for 9-14 however my futaba 14sg and r700sb are setup the same and I made sure the receiver was in mode 2 for SBUS out. Channels 1-8 show normal PWM. anyone have any ideas?

1 Like


Thanks for report, Nick. That is a bug indeed. It’s a small one, so I think we’ll fix it by the end of this week and roll the update.


Awesome! Thank you. If you need any testing when it’s updated let me know if I can help!


You can now run sudo apt-get update && sudo apt-get upgrade and use this branch to test it.

thank you George, you guys work quickly! I am trying to build the binary from source, this is my first time and I am compiling right on the PI3 to keep it simple (for me at least). That being said I am having an issue and I may not be performing the steps right, hopefully someone could guide me the right direction. I clones the experimental branch of Navio2 with the link you gave me, then I followed the steps in the documents after it was cloned… cd to ardupilot, then updated submodules, cd Ardcopter and then “make navio2-octa” ut i get “no rule to make navio2-octa stop”. Any help would be greatly appreciated!

I tried from the diydrones branch just to see if I got the same error but it made the .elf ok but when initilized is said could not open SPI bus. I cloned the link you gave me again and looked that the info in the make file in make file and tried to execute the build with different commands. I attached 2 screen shots for more info

Please post the output of uname -a and ls /dev/spidev*. Do you use the image we provided or the official Raspbian from Raspberry Pi Foundation? It looks like either upgrade corrupted something or you’re using the stock image. The other possibility might be due to changes in raspi-config. Have you used the latter utility?

In order to compile newer versions like the one I attached, you need to use the newer build system called waf. Here are the instructions.

Thanks again for the quick reply. I’ve only used Emlid images and update commands listed forums/docs so not to mess with the rt kernel.(I’m still learning Linux so trying to be careful) but I did use raspi configto look at the options… I don’t think I changed anything but maybe. I can start with a fresh image tomorrow and start over. Will post results!

I didn’t get a chance to check the outputs for the commands you mentioned. I was too excited to get started and just wrote the image (from emlid) to the SD card. I think i was able to compile the correct branch (navio0experimental). What ever I did it built successfully and i did a quick check on ch11 with my camera and the camera did trigger! Thanks for your quick help.

I just went through calibration and seem to have bad compass errors. Nothing has changed since loading the navio-experimental branch. Did one of the compass offsets change? Before I could get compass 1 and 2 offsets in the green, now 1 is yellow and 2 is green but as soon as its moved it gets EKF and error compass variance rises to 1.5. Tried to calibrate outside after first failed attempt but no luck. tried about 5 times. Any suggestions?


Have you looked at the tips in this entry in our docs? I suggest use second compass and reboot. I hope, it’ll help!

Yes, followed it exactly but no luck.


Perhaps you haven’t calibrated accelerometer? The newest EKF has stricter bounds and navio-experimental is indeed a bit experimental at the moment :frowning: Compass variance is usually due to some calibration issues, though!

I will try again but I went through the whole setup a few times. I am thinking that of the issue isn’t with the mail experimental branch then it’s something I did in the build. I am new to cloning branches and building from them. Is your latest packed from master? If so maybe I can clone that branch and just edit the navio2 rc input from 8 to 14 channels and not rely on the whole experimental branch.

I must have built arducopter wrong the first time or wrong branch. I tried it again and after doing it once it was a bit more clear how to do it. I calibrated compasses and got good offsets but also ekf compass variance is staying at 0.00 Pixhawk was from 0.00 to 0.03 when i was using it…Thanks for all your help!