No actual visualization of position in Emlid Flow

Hi there,

In the latest Emlid Flow version I can’t see my position on the map. I attached a screenshot.
The Stake Out Mode is a workaround to see where I am located but that’s not that great.

Any suggestions?

I am running Emlid Flow (V8.6) on a Sony Xperia 1 IV with Android 13.

It also happens to me on Motorola g71, it must be a development problem. I have to restart the application to see the position of the rover

Hi Marius,

I’ve passed the details to our devs for a closer look. Once there’s any news, I’ll let you know.

Do I understand correctly that it works the same way in the new Emlid Flow 8.8?

Hi @kseniia.suzdaltseva
Still the same problem, I updated the flow to 8.8. Only when I move I get the arrow with my heading direction.



I see, thank you! Our devs are working on an update that should help with the missing rover icon. I’ll get back to you once it’s out.

I think the update of today worked.
Thanks :slight_smile:

I guess I have to go back. If I open a different app without closing Emlid Flow complete the same problem appears again.

Hi Marius,

Do you mean that the icon disappears when you get back to Emlid Flow after opening another app?

Hi Kseniia,
exactly. It is quite a work around to restart Emlid Flow every time to see my position.
Hopefully an update will help.


Got it, thanks! Passed the details to the team. We’ll look into it.

I’m having this issue with Emlid Flow 9.1 while shooting points. The points show up after shooting but the Base and Rover positions aren’t shown like they use to.

Update: It’s working today.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.